telephony/net/asterisk/patches/100-build-reproducibly.patch
Sebastian Kemper d6fe18bcdc asterisk: update to 18.2.2
Patches removed because uclibc was dropped:

001-disable-semaphores-on-uclibc-otherwise-allow.patch
002-configure-fix-detection-of-re-entrant-resolver-funct.patch

Patches updated/refreshed:

100-build-reproducibly.patch
140-use-default-lua.patch

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
2021-03-14 18:14:44 +01:00

29 lines
904 B
Diff

--- a/build_tools/make_build_h
+++ b/build_tools/make_build_h
@@ -5,6 +5,14 @@ MACHINE=`uname -m | sed 's/\\\\/\\\\\\\
OS=`uname -s`
USER=`id | awk -F")" '{print $1}'| awk -F"(" '{print $2}' | sed 's/\\\\/\\\\\\\\/g'`
DATE=`date -u "+%Y-%m-%d %H:%M:%S"`
+if [ -n "${SOURCE_DATE_EPOCH}" ]; then
+ # building reproducibly, faking some data
+ HOSTNAME='openwrt.org'
+ KERNEL='unknown'
+ MACHINE='unknown'
+ USER='nobody'
+ DATE=`date -u "+%Y-%m-%d %H:%M:%S" -d @${SOURCE_DATE_EPOCH}`
+fi
cat << END
/*
* build.h
--- a/Makefile
+++ b/Makefile
@@ -489,7 +489,7 @@ doc/core-en_US.xml: makeopts .lastclean
@echo "<docs xmlns:xi=\"http://www.w3.org/2001/XInclude\">" >> $@
@for x in $(MOD_SUBDIRS); do \
printf "$$x " ; \
- for i in `find $$x -name '*.c'`; do \
+ for i in `find $$x -name '*.c' | LC_ALL=C sort`; do \
$(AWK) -f build_tools/get_documentation $$i >> $@ ; \
done ; \
done