telephony/net/kamailio/patches/140-redis_use_pkg-config.patch
Sebastian Kemper 7163789ee1 kamailio: bump to 5.6.2
- 4 new modules: misctest, posops, siprepo & slack
- 140-redis_use_pkg-config.patch refreshed
- 160-ldap-rename-private-function-ldap_connect.patch and
  170-core-add-support-for-time64-libcs.patch removed (applied
  upstream)
- 160-siputils-fix-time_t-warning-and-a-typo.patch added to fix time_t
  warning (sent upstream, see [1])

[1] https://github.com/kamailio/kamailio/pull/3266

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
2022-10-16 17:40:43 +02:00

65 lines
1.7 KiB
Diff

--- a/src/modules/cnxcc/Makefile
+++ b/src/modules/cnxcc/Makefile
@@ -8,12 +8,10 @@ include ../../Makefile.defs
auto_gen=
NAME=cnxcc.so
-ifeq ($(CROSS_COMPILE),)
HIREDIS_BUILDER = $(shell \
if pkg-config --exists hiredis; then \
echo 'pkg-config hiredis'; \
fi)
-endif
ifeq ($(HIREDIS_BUILDER),)
HIREDISDEFS=-I$(LOCALBASE)/include
--- a/src/modules/db_redis/Makefile
+++ b/src/modules/db_redis/Makefile
@@ -5,7 +5,6 @@ include ../../Makefile.defs
auto_gen=
NAME=db_redis.so
-ifeq ($(CROSS_COMPILE),)
HIREDIS_BUILDER = $(shell \
if pkg-config --exists hiredis; then \
echo 'pkg-config hiredis'; \
@@ -16,8 +15,6 @@ HIREDIS_CLUSTER_BUILDER = $(shell \
echo 'pkg-config hiredis_cluster'; \
fi)
-endif
-
ifeq ($(HIREDIS_BUILDER),)
HIREDISDEFS=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/hiredis -I/usr/include/hiredis
HIREDISLIBS=-L$(LOCALBASE)/lib -lhiredis
--- a/src/modules/ndb_redis/Makefile
+++ b/src/modules/ndb_redis/Makefile
@@ -5,12 +5,10 @@ include ../../Makefile.defs
auto_gen=
NAME=ndb_redis.so
-ifeq ($(CROSS_COMPILE),)
HIREDIS_BUILDER = $(shell \
if pkg-config --exists hiredis; then \
echo 'pkg-config hiredis'; \
fi)
-endif
ifeq ($(HIREDIS_BUILDER),)
HIREDISDEFS=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/hiredis -I/usr/include/hiredis
--- a/src/modules/topos_redis/Makefile
+++ b/src/modules/topos_redis/Makefile
@@ -5,12 +5,10 @@ include ../../Makefile.defs
auto_gen=
NAME=topos_redis.so
-ifeq ($(CROSS_COMPILE),)
HIREDIS_BUILDER = $(shell \
if pkg-config --exists hiredis; then \
echo 'pkg-config hiredis'; \
fi)
-endif
ifeq ($(HIREDIS_BUILDER),)
HIREDISDEFS=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/hiredis -I/usr/include/hiredis