telephony/net/asterisk/patches/170-menuselect-force-use-of-xml2-config.patch
Sebastian Kemper aa3bc352e7 asterisk: bump to 18.14.0
- add new modules
- res-geolocation depends on asterisk being built with libxlt support,
  but to make libxslt a general dependency is probably not a good idea
  for small devices, so this adds a config option
  ASTERISK_LIBXSLT_SUPPORT that is off by default except on x86_64
  builds
- correct some module titles by removing the extraneous "support" string
- refresh patches
- 170-time-add-support-for-time64-libcs.patch,
  180_build-fix-bininstall-launchd-issue-on-cross-platfrom.patch and
  190-logger-workaround-woefully-small-BUFSIZ-in-MUSL.patch removed as
  included in upstream release
- added 170-menuselect-force-use-of-xml2-config.patch as upstream
  switched to use pkg-config for libxml2 detection, which would be fine,
  except OpenWrt's host libxml2 is static and Asterisk can't handle that

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
2022-08-20 17:12:39 +02:00

18 lines
672 B
Diff

Since commit dc701d6 in the OpenWrt packages repo the host libxml2 package
provides a static lib only. But Asterisk does not check that and calls
pkg-config without "--static". The result is that menuselect doesn't build.
So don't use pkg-config for the libxml2 detection. Asterisk will resort to
use xml2-config, which outputs all the flags needed.
--- a/menuselect/configure.ac
+++ b/menuselect/configure.ac
@@ -91,7 +91,6 @@ else
AST_EXT_LIB_CHECK([TINFO], [tinfo], [keypad], [curses.h])
fi
-AST_PKG_CONFIG_CHECK([LIBXML2], [libxml-2.0])
AST_EXT_TOOL_CHECK([LIBXML2], [xml2-config], , ,
[#include <libxml/tree.h>
#include <libxml/parser.h>],