mirror of
https://github.com/openwrt/telephony.git
synced 2025-05-02 10:31:03 +08:00

Fixes compilation under musl 1.2.x where time_t is 64-bit. Signed-off-by: Rosen Penev <rosenp@gmail.com>
12 lines
350 B
Diff
12 lines
350 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -68,7 +68,7 @@ DYNAMIC_OBJS= \
|
|
$(STATIC_OBJS)
|
|
CFLAGS ?= -g
|
|
CFLAGS += $(CPPFLAGS)
|
|
-CFLAGS += -Wall -Werror -Wstrict-prototypes -Wmissing-prototypes
|
|
+CFLAGS += -Wall -Wstrict-prototypes -Wmissing-prototypes
|
|
CFLAGS += -fPIC $(ALERTING) $(LIBPRI_OPT) $(COVERAGE_CFLAGS)
|
|
INSTALL_PREFIX=$(DESTDIR)
|
|
INSTALL_BASE=/usr
|