telephony/net/asterisk/patches/140-use-default-lua.patch
Sebastian Kemper b936fade67 asterisk: upgrade to Asterisk 18 LTS
- Bump to new LTS release.
- Move to folder asterisk and remove AST_MAJOR_VERSION variable, as we
  only have one version anyway.
- Add new modules.
- Rename voicemail to app-voicemail.
- Remove deps of voicemail on res-adsi and res-smdi as they are
  optional.
- Use INSTALL_DATA for headers.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
2020-11-01 09:37:46 +01:00

16 lines
668 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -2560,7 +2560,11 @@ if test -z "$__opus_include" -o x"$__opu
fi
AST_EXT_LIB_CHECK([OPUSFILE], [opusfile], [op_open_callbacks], [opus/opusfile.h], [], [$__opus_include])
-for ver in 5.3 5.2 5.1; do
+# This does not work for us. We have both liblua and liblua5.3 in
+# $(STAGING_DIR)/usr. But the headers for liblua5.3 are in
+# (STAGING_DIR)/usr/include/lua5.3. Using the below, Asterisk would
+# use the headers from liblua and link against liblua5.3 :/
+for ver in ; do
AST_EXT_LIB_CHECK([LUA], lua${ver}, [luaL_newstate], lua${ver}/lua.h, [-lm])
if test "x${PBX_LUA}" = "x1" ; then
if test x"${LUA_DIR}" = x; then