telephony/net/asterisk/patches/140-use-default-lua.patch
Sebastian Kemper aa3bc352e7 asterisk: bump to 18.14.0
- add new modules
- res-geolocation depends on asterisk being built with libxlt support,
  but to make libxslt a general dependency is probably not a good idea
  for small devices, so this adds a config option
  ASTERISK_LIBXSLT_SUPPORT that is off by default except on x86_64
  builds
- correct some module titles by removing the extraneous "support" string
- refresh patches
- 170-time-add-support-for-time64-libcs.patch,
  180_build-fix-bininstall-launchd-issue-on-cross-platfrom.patch and
  190-logger-workaround-woefully-small-BUFSIZ-in-MUSL.patch removed as
  included in upstream release
- added 170-menuselect-force-use-of-xml2-config.patch as upstream
  switched to use pkg-config for libxml2 detection, which would be fine,
  except OpenWrt's host libxml2 is static and Asterisk can't handle that

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
2022-08-20 17:12:39 +02:00

12 lines
446 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -2613,7 +2613,7 @@ if test -z "$__opus_include" -o x"$__opu
fi
AST_EXT_LIB_CHECK([OPUSFILE], [opusfile], [op_open_callbacks], [opus/opusfile.h], [], [$__opus_include])
-for ver in ${LUA_VERSIONS:-5.4 5.3 5.2 5.1}; do
+for ver in ${LUA_VERSIONS}; do
AST_EXT_LIB_CHECK([LUA], lua${ver}, [luaL_newstate], lua${ver}/lua.h, [-lm])
if test "x${PBX_LUA}" = "x1" ; then
if test x"${LUA_DIR}" = x; then