telephony/net/asterisk/patches/130-eventfd.patch
Daniel Golle 11353e1a17 asterisk: update to version 20.8.1
Update to most recent LTS release addressing multiple security and
stability issues.

Complete changelog:
https://github.com/asterisk/asterisk/compare/20.5.2...20.8.1

Note that res-stir-shaken switched to use libjwt instead of providing
a built-in JWT implementation.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
2024-06-24 01:46:09 +01:00

12 lines
330 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -1272,7 +1272,7 @@ if test "${ac_cv_have_variable_fdset}x"
fi
AC_MSG_CHECKING([if we have usable eventfd support])
-AC_RUN_IFELSE(
+AC_LINK_IFELSE(
[AC_LANG_PROGRAM([#include <sys/eventfd.h>],
[return eventfd(0, EFD_NONBLOCK | EFD_SEMAPHORE) == -1;])],
AC_MSG_RESULT(yes)