mirror of
https://github.com/openwrt/telephony.git
synced 2025-05-03 16:00:04 +08:00

- patches which are now upstream were removed - some patches were refreshed - 003-modmake-fix.patch was amended a bit because of upstream commit 91f12b5 (it changed tests/unit/Makefile.am so that it doesn't redefine AM_CFLAGS and AM_CPPFLAGS, which results in duplicated flags) Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
91 lines
2.3 KiB
Diff
91 lines
2.3 KiB
Diff
--- a/libs/apr-util/build/apr_common.m4
|
|
+++ b/libs/apr-util/build/apr_common.m4
|
|
@@ -514,8 +514,9 @@ dnl string.
|
|
dnl
|
|
dnl
|
|
AC_DEFUN([APR_CHECK_STRERROR_R_RC],[
|
|
-AC_MSG_CHECKING(for type of return code from strerror_r)
|
|
-AC_TRY_RUN([
|
|
+AC_CACHE_CHECK([whether return code from strerror_r has type int],
|
|
+[ac_cv_strerror_r_rc_int],
|
|
+[AC_TRY_RUN([
|
|
#include <errno.h>
|
|
#include <string.h>
|
|
#include <stdio.h>
|
|
@@ -534,14 +535,10 @@ int main(void)
|
|
}], [
|
|
ac_cv_strerror_r_rc_int=yes ], [
|
|
ac_cv_strerror_r_rc_int=no ], [
|
|
- ac_cv_strerror_r_rc_int=no ] )
|
|
+ ac_cv_strerror_r_rc_int=no ] ) ] )
|
|
if test "x$ac_cv_strerror_r_rc_int" = xyes; then
|
|
AC_DEFINE(STRERROR_R_RC_INT, 1, [Define if strerror returns int])
|
|
- msg="int"
|
|
-else
|
|
- msg="pointer"
|
|
fi
|
|
-AC_MSG_RESULT([$msg])
|
|
] )
|
|
|
|
dnl
|
|
--- a/libs/apr/build/apr_common.m4
|
|
+++ b/libs/apr/build/apr_common.m4
|
|
@@ -514,8 +514,9 @@ dnl string.
|
|
dnl
|
|
dnl
|
|
AC_DEFUN([APR_CHECK_STRERROR_R_RC],[
|
|
-AC_MSG_CHECKING(for type of return code from strerror_r)
|
|
-AC_TRY_RUN([
|
|
+AC_CACHE_CHECK([whether return code from strerror_r has type int],
|
|
+[ac_cv_strerror_r_rc_int],
|
|
+[AC_TRY_RUN([
|
|
#include <errno.h>
|
|
#include <string.h>
|
|
#include <stdio.h>
|
|
@@ -534,14 +535,10 @@ int main(void)
|
|
}], [
|
|
ac_cv_strerror_r_rc_int=yes ], [
|
|
ac_cv_strerror_r_rc_int=no ], [
|
|
- ac_cv_strerror_r_rc_int=no ] )
|
|
+ ac_cv_strerror_r_rc_int=no ] ) ] )
|
|
if test "x$ac_cv_strerror_r_rc_int" = xyes; then
|
|
AC_DEFINE(STRERROR_R_RC_INT, 1, [Define if strerror returns int])
|
|
- msg="int"
|
|
-else
|
|
- msg="pointer"
|
|
fi
|
|
-AC_MSG_RESULT([$msg])
|
|
] )
|
|
|
|
dnl
|
|
--- a/libs/unimrcp/build/acmacros/apr_common.m4
|
|
+++ b/libs/unimrcp/build/acmacros/apr_common.m4
|
|
@@ -526,8 +526,9 @@ dnl string.
|
|
dnl
|
|
dnl
|
|
AC_DEFUN([APR_CHECK_STRERROR_R_RC], [
|
|
-AC_MSG_CHECKING(for type of return code from strerror_r)
|
|
-AC_TRY_RUN([
|
|
+AC_CACHE_CHECK([whether return code from strerror_r has type int],
|
|
+[ac_cv_strerror_r_rc_int],
|
|
+[AC_TRY_RUN([
|
|
#include <errno.h>
|
|
#include <string.h>
|
|
#include <stdio.h>
|
|
@@ -543,14 +544,10 @@ main()
|
|
}], [
|
|
ac_cv_strerror_r_rc_int=yes ], [
|
|
ac_cv_strerror_r_rc_int=no ], [
|
|
- ac_cv_strerror_r_rc_int=no ] )
|
|
+ ac_cv_strerror_r_rc_int=no ] ) ] )
|
|
if test "x$ac_cv_strerror_r_rc_int" = xyes; then
|
|
AC_DEFINE(STRERROR_R_RC_INT, 1, [Define if strerror returns int])
|
|
- msg="int"
|
|
-else
|
|
- msg="pointer"
|
|
fi
|
|
-AC_MSG_RESULT([$msg])
|
|
] )
|
|
|
|
dnl
|