telephony/net/asterisk/patches/140-use-default-lua.patch
Rosen Penev 90281b85eb
asterisk: fix compilation with 1.2.x
Needs _DECLS and __P definitions.

Refreshed other patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2021-02-22 22:54:46 -08:00

16 lines
672 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -2564,7 +2564,11 @@ if test -z "$__opus_include" -o x"$__opu
fi
AST_EXT_LIB_CHECK([OPUSFILE], [opusfile], [op_open_callbacks], [opus/opusfile.h], [], [$__opus_include])
-for ver in 5.4 5.3 5.2 5.1; do
+# This does not work for us. We have both liblua and liblua5.3 in
+# $(STAGING_DIR)/usr. But the headers for liblua5.3 are in
+# (STAGING_DIR)/usr/include/lua5.3. Using the below, Asterisk would
+# use the headers from liblua and link against liblua5.3 :/
+for ver in ; do
AST_EXT_LIB_CHECK([LUA], lua${ver}, [luaL_newstate], lua${ver}/lua.h, [-lm])
if test "x${PBX_LUA}" = "x1" ; then
if test x"${LUA_DIR}" = x; then