telephony/libs/dahdi-linux/patches/070-no-firmware-blob-download.patch
Daniel Golle 6dd432b5be dahdi-linux: skip blob firmware download
DAHDI tries downloading firmware blobs from Digium's server which are
for hardware not supported by the OpenWrt package and those blobs are
licensed prohibiting redistribution. Thus there is no point in
downloading them at all, especially as the download failing frequently
causes build failures.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
2016-01-19 11:15:31 +01:00

18 lines
541 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -80,12 +80,12 @@ include/dahdi/version.h: FORCE
fi
@rm -f $@.tmp
-prereq: include/dahdi/version.h firmware-loaders
+prereq: include/dahdi/version.h
stackcheck: $(CHECKSTACK) modules
objdump -d drivers/dahdi/*.ko drivers/dahdi/*/*.ko | $(CHECKSTACK)
-install: all install-modules install-include install-firmware install-xpp-firm
+install: all install-modules install-include
@echo "###################################################"
@echo "###"
@echo "### DAHDI installed successfully."