mirror of
https://github.com/openwrt/telephony.git
synced 2025-05-02 13:49:26 +08:00
commit
f9b91a196f
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libsrtp
|
||||
PKG_VERSION:=2.3.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=2.4.2
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=libsrtp-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/cisco/libsrtp/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=94093a5d04c5f4743e8d81182b76938374df6d393b45322f24960d250b0110e8
|
||||
PKG_HASH:=3b1bcb14ebda572b04b9bdf07574a449c84cb924905414e4d94e62837d22b628
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
@ -26,8 +26,9 @@ define Package/libsrtp2
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Secure RTP (SRTP) library, v$(PKG_VERSION)
|
||||
URL:=http://sourceforge.net/projects/srtp
|
||||
URL:=https://github.com/cisco/libsrtp
|
||||
DEPENDS:=
|
||||
ABI_VERSION:=1
|
||||
endef
|
||||
|
||||
define Package/libsrtp2/description
|
||||
@ -52,7 +53,7 @@ endef
|
||||
define Package/libsrtp2/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libsrtp2.so.* \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libsrtp2.so.$(ABI_VERSION)* \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/crypto/math/datatypes.c
|
||||
+++ b/crypto/math/datatypes.c
|
||||
@@ -79,7 +79,7 @@ int octet_get_weight(uint8_t octet)
|
||||
|
||||
/* the value MAX_PRINT_STRING_LEN is defined in datatypes.h */
|
||||
|
||||
-char bit_string[MAX_PRINT_STRING_LEN];
|
||||
+static char bit_string[MAX_PRINT_STRING_LEN];
|
||||
|
||||
uint8_t srtp_nibble_to_hex_char(uint8_t nibble)
|
||||
{
|
@ -14,7 +14,7 @@ PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/sippy/rtpproxy.git
|
||||
PKG_SOURCE_DATE=2019-10-02
|
||||
PKG_SOURCE_VERSION:=aa1f179e09097f467bc4726e3300014c1e35246f
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_MIRROR_HASH:=7acc5f5bf2d4be23e9a2fad0c4e7576f172191c9f1b37104aee4d05dbdcac8fd
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
@ -39,8 +39,6 @@ Date: Thu Oct 3 19:58:08 2019 +0200
|
||||
|
||||
Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 6e680c63..fe3216b6 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -140,22 +140,22 @@ then
|
||||
|
@ -0,0 +1,23 @@
|
||||
From f6c1f9e5924246216a05c295f450989ad9c80104 Mon Sep 17 00:00:00 2001
|
||||
From: Maksym Sobolyev <sobomax@sippysoft.com>
|
||||
Date: Thu, 13 May 2021 11:42:29 -0700
|
||||
Subject: [PATCH] Resolve build breakage after ekt member of the policy struct
|
||||
has been deprecated by the libsrtp. We have not been using that member to do
|
||||
anything meaningful anyhow and the struct is inied to \0, so it should have
|
||||
no adverse effect.
|
||||
|
||||
---
|
||||
extractaudio/eaud_crypto.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/extractaudio/eaud_crypto.c
|
||||
+++ b/extractaudio/eaud_crypto.c
|
||||
@@ -153,7 +153,7 @@ eaud_crypto_getopt_parse(char *optarg)
|
||||
srtp_crypto_policy_set_rtp_default(&rval->policy.rtp);
|
||||
srtp_crypto_policy_set_rtcp_default(&rval->policy.rtcp);
|
||||
rval->policy.key = (uint8_t *)rval->key;
|
||||
- rval->policy.ekt = NULL; rval->policy.next = NULL;
|
||||
+ rval->policy.next = NULL;
|
||||
rval->policy.window_size = 128;
|
||||
rval->policy.allow_repeat_tx = 0;
|
||||
rval->policy.rtp.auth_tag_len = suite->tag_size;
|
Loading…
Reference in New Issue
Block a user