mirror of
https://github.com/openwrt/telephony.git
synced 2025-05-02 02:10:03 +08:00
Merge pull request #883 from robho/yate_github
yate: bump to git snapshot from 2024-09-03
This commit is contained in:
commit
d6f42a48d2
@ -9,12 +9,13 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=yate
|
PKG_NAME:=yate
|
||||||
PKG_VERSION:=6.4.0-1
|
PKG_RELEASE:=1
|
||||||
PKG_RELEASE:=3
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=http://yate.null.ro/tarballs/yate6/
|
PKG_SOURCE_URL:=https://github.com/yatevoip/yate.git
|
||||||
PKG_HASH:=8c23dc6bffbf8d478db3a85964b5019771c8f6c9acf5220f3465516a748a03b0
|
PKG_SOURCE_DATE:=2024-09-03
|
||||||
|
PKG_SOURCE_VERSION:=d009381e4920e608dc2aae847c56469d471a8c48
|
||||||
|
PKG_MIRROR_HASH:=eb85e127df46de9aea20f98b28b23897de631da972b6ae6e312338fcf86c0cfd
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-2.0
|
PKG_LICENSE:=GPL-2.0
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
@ -51,14 +52,11 @@ ifeq ($(CONFIG_HOST_OS_MACOS),y)
|
|||||||
include $(TOPDIR)/feeds/packages/utils/fakeuname/fakeuname.mk
|
include $(TOPDIR)/feeds/packages/utils/fakeuname/fakeuname.mk
|
||||||
endif
|
endif
|
||||||
|
|
||||||
TAR_OPTIONS+= --strip-components 1
|
|
||||||
TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)
|
|
||||||
|
|
||||||
define Package/$(PKG_NAME)/Default
|
define Package/$(PKG_NAME)/Default
|
||||||
SUBMENU:=Telephony
|
SUBMENU:=Telephony
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
URL:=http://yate.null.ro/
|
URL:=https://yate.ro/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/$(PKG_NAME)
|
define Package/$(PKG_NAME)
|
||||||
@ -100,6 +98,7 @@ CONFIGURE_VARS+= \
|
|||||||
$(if $(CONFIG_HOST_OS_MACOS),PATH=$(FAKEUNAME_PATH):$(TARGET_PATH_PKG))
|
$(if $(CONFIG_HOST_OS_MACOS),PATH=$(FAKEUNAME_PATH):$(TARGET_PATH_PKG))
|
||||||
|
|
||||||
CONFIGURE_ARGS+= \
|
CONFIGURE_ARGS+= \
|
||||||
|
--disable-atomics \
|
||||||
--disable-sctp \
|
--disable-sctp \
|
||||||
--disable-tdmcard \
|
--disable-tdmcard \
|
||||||
--disable-wanpipe \
|
--disable-wanpipe \
|
||||||
@ -139,6 +138,22 @@ CONFIGURE_ARGS+= \
|
|||||||
--disable-isac-float
|
--disable-isac-float
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
(cd $(PKG_BUILD_DIR); ./yate-config.sh)
|
||||||
|
$(call Build/Configure/Default)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Install
|
||||||
|
$(call Build/Install/Default,install-noapi)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
$(INSTALL_DIR) $(STAGING_DIR)/usr/include
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(STAGING_DIR)/usr/include/
|
||||||
|
$(INSTALL_DIR) $(STAGING_DIR)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(STAGING_DIR)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/$(PKG_NAME)/install
|
define Package/$(PKG_NAME)/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
|
||||||
@ -165,13 +180,6 @@ define Package/$(PKG_NAME)-sounds/install
|
|||||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/yate/sounds/ $(1)/usr/share/yate/
|
$(CP) $(PKG_INSTALL_DIR)/usr/share/yate/sounds/ $(1)/usr/share/yate/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(STAGING_DIR)/usr/include
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(STAGING_DIR)/usr/include/
|
|
||||||
$(INSTALL_DIR) $(STAGING_DIR)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(STAGING_DIR)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define BuildPlugin
|
define BuildPlugin
|
||||||
define Package/$(PKG_NAME)-mod-$(subst _,-,$(1))
|
define Package/$(PKG_NAME)-mod-$(subst _,-,$(1))
|
||||||
$(call Package/yate/Default)
|
$(call Package/yate/Default)
|
||||||
|
@ -13,7 +13,7 @@
|
|||||||
#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__APPLE__)
|
#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__APPLE__)
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -264,7 +264,7 @@ AC_TRY_COMPILE([
|
@@ -268,7 +268,7 @@ AC_TRY_COMPILE([
|
||||||
#include <pthread.h>
|
#include <pthread.h>
|
||||||
],[
|
],[
|
||||||
pthread_mutexattr_t attr;
|
pthread_mutexattr_t attr;
|
||||||
|
Loading…
Reference in New Issue
Block a user