packages/utils/rrdtool1/patches/050-no-doc.patch
zhusir c0d085c323
rrdtool1: Sync with openwrt/packages (#544)
* rrdtool1: refresh `PKG_HASH`

* Fixes compilation without host pod2man.

Signed-off-by: Rosen Penev <rosenp@gmail.com>

Adjust to the 64 bit time_t in musl 1.2.2 by keeping time
internally in RRD still as 'long', so that old databases
created during musl 1.1.x still work in 32 bit targets.

That also helps with several interal functions that use 'long'
for calculations and printf formatting.

* Define internal type TIME_INT as 'long', and use that
  internally in calculations
* Use time_t vs. TIME_INT casting when necessary
* Provide time_t variable pointers for functions expecting
  a time_t pointer.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
2022-09-30 20:44:20 +08:00

12 lines
349 B
Diff

--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@ endif
# build the following subdirectories
SUBDIRS = cgilib-0.4 gd1.3 $(SUBDIRS_1) $(SUBDIRS_2) \
- src doc examples contrib tcl
+ src examples contrib tcl
# the following files are not mentioned in any other Makefile
# LWT 24Jul03 - removed redundant spec file listed