packages/net/xtables-addons/patches/001-fix-kernel-version-detection.patch
Philip Prindeville bc9f85977b xtables-addons: Update to 3.19
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
2022-02-27 16:51:24 +00:00

12 lines
435 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -42,7 +42,7 @@ regular_CFLAGS="-Wall -Waggregate-return
AS_IF([test -n "$kbuilddir"], [
AC_MSG_CHECKING([kernel version that we will build against])
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
save_IFS="$IFS"
IFS='.'
set x $krel