mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-02 03:00:58 +08:00
14 lines
621 B
Diff
14 lines
621 B
Diff
--- a/builders/make/linux.mk
|
|
+++ b/builders/make/linux.mk
|
|
@@ -31,8 +31,8 @@ OPTIMIZATIONS = -O3
|
|
COMPILE_FLAGS = $(FPIC) $(OPTIMIZATIONS) $(CFLAGS)
|
|
|
|
#linking flags
|
|
-dynamic_lib_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-soname,$(DYNAMIC_LIB_PREFIX)$(1)$(DYNAMIC_LIB_SUFIX) -Wl,-rpath,"\$$ORIGIN"
|
|
-dynamic_exec_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-rpath,"\$$ORIGIN"
|
|
+dynamic_lib_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-soname,$(DYNAMIC_LIB_PREFIX)$(1)$(DYNAMIC_LIB_SUFIX) -Wl,-rpath,/usr/lib/crtmpserver
|
|
+dynamic_exec_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-rpath,/usr/lib/crtmpserver
|
|
|
|
#compile switches
|
|
PLATFORM_DEFINES = \
|