mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-03 10:22:34 +08:00
18 lines
581 B
Diff
18 lines
581 B
Diff
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -1,3 +1,4 @@
|
|
+import os
|
|
from setuptools import setup, find_packages
|
|
|
|
|
|
@@ -6,8 +7,7 @@ def main():
|
|
name='py',
|
|
description='library with cross-python path, ini-parsing, io, code, log facilities',
|
|
long_description=open('README.rst').read(),
|
|
- use_scm_version={"write_to": "py/_version.py"},
|
|
- setup_requires=["setuptools-scm"],
|
|
+ version=os.getenv('PKG_VERSION'),
|
|
url='http://py.readthedocs.io/',
|
|
license='MIT license',
|
|
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
|