packages/lang/python/python3/patches/015-abort-on-failed-modules.patch
Jeffery To 0c2effae56 python3: Update to 3.9.10, refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
2022-03-06 03:22:20 +08:00

11 lines
322 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -526,6 +526,7 @@ class PyBuildExt(build_ext):
print("Failed to build these modules:")
print_three_column(failed)
print()
+ if CROSS_COMPILING: sys.exit(1)
if self.failed_on_import:
failed = self.failed_on_import[:]