packages/lang/python/python3/patches/010-do-not-add-rt-lib-dirs-when-cross-compiling.patch
breakings ae4ac3c2c7
python3: Update to 3.9.12 (#407)
* python3: Update to 3.9.11, refresh patches

Includes fixes for:
* Windows builds updated to bzip2 1.0.8 to mitigate CVE-2016-3189 and
  CVE-2019-12900
* CVE-2022-26488: Escalation of privilege via Windows Installer

Signed-off-by: Jeffery To <jeffery.to@gmail.com>

* python3: Update to 3.9.12

Signed-off-by: Jeffery To <jeffery.to@gmail.com>

Co-authored-by: Jeffery To <jeffery.to@gmail.com>
2022-04-13 13:38:07 +08:00

14 lines
758 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -719,8 +719,9 @@ class PyBuildExt(build_ext):
# directly since an inconsistently reproducible issue comes up where
# the environment variable is not set even though the value were passed
# into configure and stored in the Makefile (issue found on OS X 10.3).
+ rt_lib_dirs = [] if CROSS_COMPILING else self.compiler.runtime_library_dirs
for env_var, arg_name, dir_list in (
- ('LDFLAGS', '-R', self.compiler.runtime_library_dirs),
+ ('LDFLAGS', '-R', rt_lib_dirs),
('LDFLAGS', '-L', self.compiler.library_dirs),
('CPPFLAGS', '-I', self.compiler.include_dirs)):
env_val = sysconfig.get_config_var(env_var)