mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-02 23:51:07 +08:00
12 lines
363 B
Diff
12 lines
363 B
Diff
--- a/ports/unix/Makefile
|
|
+++ b/ports/unix/Makefile
|
|
@@ -36,7 +36,7 @@ INC += -I$(TOP)
|
|
INC += -I$(BUILD)
|
|
|
|
# compiler settings
|
|
-CWARN = -Wall -Werror
|
|
+CWARN = -Wall
|
|
CWARN += -Wextra -Wno-unused-parameter -Wpointer-arith -Wdouble-promotion -Wfloat-conversion
|
|
CFLAGS += $(INC) $(CWARN) -std=gnu99 -DUNIX $(CFLAGS_MOD) $(COPT) -I$(VARIANT_DIR) $(CFLAGS_EXTRA)
|
|
|