mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-02 04:51:52 +08:00

Previous versions used a bundled version of the axTLS library. The MicroPython project maintains their own fork[1], as development of the library appears to have stopped (the last release was version 2.1.5 in 2019[2]). This replaces the use of axTLS with two variants, one using mbedTLS and one with no TLS support (and no upip, as it uses the ussl module). The external mbedTLS patch (040-extmod-use-external-mbedtls.patch) comes from Debian[3]. This also sets myself as the maintainer. [1]: https://github.com/micropython/axtls [2]: https://sourceforge.net/projects/axtls/files/ [3]: https://salsa.debian.org/yangfl-guest/micropython/-/blob/master/debian/patches/0006-extmod-Use-system-mbedtls.patch Signed-off-by: Jeffery To <jeffery.to@gmail.com>
12 lines
363 B
Diff
12 lines
363 B
Diff
--- a/ports/unix/Makefile
|
|
+++ b/ports/unix/Makefile
|
|
@@ -38,7 +38,7 @@ INC += -I$(TOP)
|
|
INC += -I$(BUILD)
|
|
|
|
# compiler settings
|
|
-CWARN = -Wall -Werror
|
|
+CWARN = -Wall
|
|
CWARN += -Wextra -Wno-unused-parameter -Wpointer-arith -Wdouble-promotion -Wfloat-conversion
|
|
CFLAGS += $(INC) $(CWARN) -std=gnu99 -DUNIX $(CFLAGS_MOD) $(COPT) -I$(VARIANT_DIR) $(CFLAGS_EXTRA)
|
|
|