mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-02 06:31:41 +08:00

Update wget to 1.21.3 * Remove patch 100-fix-hsts-time.patch as upstream has issued its own version on the fixes * Add a hack (and fixup autoreconf) to fix an upstream bug that forces the nettle library into nossl even if NTLM is disabled. Upstream bug filed: https://savannah.gnu.org/bugs/?63431 * Remove old maintainer who has not been active Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
19 lines
544 B
Diff
19 lines
544 B
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -630,6 +630,7 @@ then
|
|
AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
|
fi
|
|
else
|
|
+ if test x"$ENABLE_NTLM" != xno; then
|
|
PKG_CHECK_MODULES([NETTLE], nettle, [
|
|
HAVE_NETTLE=yes
|
|
LIBS="$NETTLE_LIBS $LIBS"
|
|
@@ -651,6 +652,7 @@ else
|
|
ENABLE_NTLM=yes
|
|
AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
|
fi
|
|
+ fi
|
|
fi
|
|
|
|
dnl **********************************************************************
|