mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-04-30 22:23:17 +08:00
gptfdisk: fix compile issues (#774)
This commit is contained in:
parent
95cf76b673
commit
f36b2d2197
@ -8,18 +8,19 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gptfdisk
|
||||
PKG_VERSION:=1.0.8
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_VERSION:=1.0.9
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_HASH:=95d19856f004dabc4b8c342b2612e8d0a9eebdd52004297188369f152e9dc6df
|
||||
PKG_HASH:=dafead2693faeb8e8b97832b23407f6ed5b3219bc1784f482dd855774e2d50c2
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_FLAGS:=gc-sections lto
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -72,8 +73,9 @@ define Package/fixparts/description
|
||||
Master Boot Record (MBR) partition tables
|
||||
endef
|
||||
|
||||
TARGET_CXXFLAGS += -std=c++11 -ffunction-sections -fdata-sections -fno-rtti -flto -Wno-format-security
|
||||
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
||||
TARGET_CXXFLAGS += -std=c++11 -fno-rtti
|
||||
TARGET_LDFLAGS += -Wl,--as-needed
|
||||
MAKE_FLAGS += TARGET=linux
|
||||
|
||||
define Package/gdisk/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
@ -0,0 +1,29 @@
|
||||
From 7dfa8984f5a30f313d8675ff6097c8592d636d10 Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Mon, 12 Dec 2022 12:50:07 -0800
|
||||
Subject: [PATCH] Use 64bit time_t on linux as well
|
||||
|
||||
Alias 64bit version of stat functions to original functions
|
||||
we are already passing -D_FILE_OFFSET_BITS=64 in linux Makefile
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
---
|
||||
diskio-unix.cc | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/diskio-unix.cc
|
||||
+++ b/diskio-unix.cc
|
||||
@@ -37,8 +37,12 @@
|
||||
|
||||
using namespace std;
|
||||
|
||||
-#ifdef __APPLE__
|
||||
+#if defined(__APPLE__) || defined(__linux__)
|
||||
#define off64_t off_t
|
||||
+#define stat64 stat
|
||||
+#define fstat64 fstat
|
||||
+#define lstat64 lstat
|
||||
+#define lseek64 lseek
|
||||
#endif
|
||||
|
||||
// Returns the official "real" name for a shortened version of same.
|
Loading…
Reference in New Issue
Block a user