mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-02 12:41:51 +08:00
transmission-web-control: add package
This commit is contained in:
parent
91e9f42635
commit
ef9c58d225
41
net/transmission-web-control/Makefile
Normal file
41
net/transmission-web-control/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=transmission-web-control
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/ronggang/transmission-web-control
|
||||
PKG_SOURCE_DATE:=2019-07-24
|
||||
PKG_SOURCE_VERSION:=c27e3ba9f08148f79fb4121d8a1f5906640ff8d6
|
||||
PKG_MIRROR_HASH:=6de823b9b8229b176fbb5c9f33f326c0fb23553ae00a36f60d019fdcdf90a712
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_MAINTAINER:=Richard Yu <yurichard3839@gmail.com>
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/transmission-web-control
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=BitTorrent
|
||||
DEPENDS:=+transmission-daemon-openssl
|
||||
CONFLICTS:=transmission-web
|
||||
TITLE:=Transmission Web Control
|
||||
URL:=https://github.com/ronggang/transmission-web-control
|
||||
PKGARCH:=all
|
||||
endef
|
||||
|
||||
define Package/transmission-web-control/description
|
||||
Transmission Web Control is a custom Web UI for Transmission.
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
endef
|
||||
|
||||
define Package/transmission-web-control/install
|
||||
$(INSTALL_DIR) $(1)/usr/share/transmission/web
|
||||
$(CP) $(PKG_BUILD_DIR)/src/* $(1)/usr/share/transmission/web
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,transmission-web-control))
|
@ -0,0 +1,22 @@
|
||||
--- a/src/index.html
|
||||
+++ b/src/index.html
|
||||
@@ -61,9 +61,6 @@
|
||||
<!-- 切换到移动版 -->
|
||||
<a id="toolbar_mobile" href="javascript:location.href = 'index.mobile.html';" class="easyui-linkbutton" data-options="iconCls:'icon-mobile',plain:true" system-tip-lang="toolbar.tip['ui-mobile']"><span system-lang="toolbar['ui-mobile']"></span></a>
|
||||
<span class="button-split">|</span>
|
||||
- <!-- 切换到原版 -->
|
||||
- <a id="" href="javascript:location.href = 'index.original.html';" class="easyui-linkbutton" data-options="iconCls:'icon-transmission',plain:true" system-tip-lang="toolbar.tip['ui-original']"><span system-lang="toolbar['ui-original']"></span></a>
|
||||
- <span class="button-split">|</span>
|
||||
<!-- 关于 -->
|
||||
<a id="toolbar_about" href="javascript:void(0);" onclick="javascript:system.openDialogFromTemplate({id: 'dialog-about',options: {title: system.lang.toolbar['about'],width: 420,height: 370}});" class="easyui-linkbutton" data-options="iconCls:'icon-about',plain:true" system-tip-lang="toolbar.about"><span system-lang="toolbar.about"></span></a>
|
||||
</div>
|
||||
--- a/src/index.mobile.html
|
||||
+++ b/src/index.mobile.html
|
||||
@@ -69,7 +69,6 @@
|
||||
<ul data-role="listview" data-divider-theme="a" data-theme="c" data-icon="false" style="margin-top:15px;">
|
||||
<li data-role='list-divider'>UI</li>
|
||||
<li><a href="#" onclick="location.href = 'index.html?devicetype=computer';"><img src="tr-web-control/style/images/computer.png" class="ui-li-icon"/><span system-lang="toolbar['ui-computer']"></span></a></li>
|
||||
- <li><a href="#" onclick="location.href = 'index.original.html';"><img src="tr-web-control/style/images/transmission.png" class="ui-li-icon"/><span system-lang="toolbar['ui-original']"></span></a></li>
|
||||
</ul>
|
||||
<ul data-role="listview" data-divider-theme="a" data-theme="c" data-icon="false" style="margin-top:15px;">
|
||||
<li data-role='list-divider'><span system-lang="title.status"></span></li>
|
Loading…
Reference in New Issue
Block a user