mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 13:49:47 +08:00
commit
cf027db34b
@ -1,9 +1,10 @@
|
|||||||
menu "Kernel features for Docker"
|
menu "Kernel features for Docker"
|
||||||
depends on PACKAGE_docker-ce
|
|
||||||
|
|
||||||
config DOCKER_KERNEL_OPTIONS
|
config DOCKER_KERNEL_OPTIONS
|
||||||
bool "Enable Basic kernel support for Docker"
|
bool "Enable Basic kernel support for Docker"
|
||||||
default y
|
default n
|
||||||
|
select KERNEL_CGROUPS
|
||||||
|
select KERNEL_CGROUP_CPUACCT
|
||||||
|
select KERNEL_CGROUP_SCHED
|
||||||
select KERNEL_NAMESPACES
|
select KERNEL_NAMESPACES
|
||||||
select KERNEL_CPUSETS
|
select KERNEL_CPUSETS
|
||||||
select KERNEL_MEMCG
|
select KERNEL_MEMCG
|
||||||
@ -26,7 +27,7 @@ menu "Kernel features for Docker"
|
|||||||
|
|
||||||
config DOCKER_RES_SHAPE
|
config DOCKER_RES_SHAPE
|
||||||
bool "Enables support for resource shaping"
|
bool "Enables support for resource shaping"
|
||||||
default y
|
default n
|
||||||
select KERNEL_MEMCG_SWAP
|
select KERNEL_MEMCG_SWAP
|
||||||
select KERNEL_MEMCG_SWAP_ENABLED
|
select KERNEL_MEMCG_SWAP_ENABLED
|
||||||
select KERNEL_BLK_DEV_THROTTLING
|
select KERNEL_BLK_DEV_THROTTLING
|
||||||
@ -58,7 +59,7 @@ menu "Kernel features for Docker"
|
|||||||
|
|
||||||
config DOCKER_NET_MACVLAN
|
config DOCKER_NET_MACVLAN
|
||||||
bool "Enables macvlan kernel support"
|
bool "Enables macvlan kernel support"
|
||||||
default y
|
default n
|
||||||
select PACKAGE_kmod-macvlan
|
select PACKAGE_kmod-macvlan
|
||||||
select PACKAGE_kmod-dummy
|
select PACKAGE_kmod-dummy
|
||||||
|
|
||||||
@ -72,7 +73,7 @@ menu "Kernel features for Docker"
|
|||||||
menu "Storage"
|
menu "Storage"
|
||||||
config DOCKER_STO_EXT4
|
config DOCKER_STO_EXT4
|
||||||
bool "Enables support for ext3 or ext4 as the backing filesystem"
|
bool "Enables support for ext3 or ext4 as the backing filesystem"
|
||||||
default y
|
default n
|
||||||
select KERNEL_EXT4_FS_POSIX_ACL
|
select KERNEL_EXT4_FS_POSIX_ACL
|
||||||
|
|
||||||
config DOCKER_STO_BTRFS
|
config DOCKER_STO_BTRFS
|
||||||
|
@ -1,15 +1,15 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=docker-ce
|
PKG_NAME:=docker-ce
|
||||||
PKG_VERSION:=19.03.3
|
PKG_VERSION:=19.03.8
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=2
|
||||||
PKG_LICENSE:=Apache-2.0
|
PKG_LICENSE:=Apache-2.0
|
||||||
PKG_LICENSE_FILES:=components/cli/LICENSE components/engine/LICENSE
|
PKG_LICENSE_FILES:=components/cli/LICENSE components/engine/LICENSE
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/docker/docker-ce/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/docker/docker-ce/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_HASH:=63b0d28608f32573b9c03fa46247c6f959e9c08133ddf30a71276919de0194c0
|
PKG_HASH:=781c69e00e98f64fb167ee61de764882bd4926a873d98ce6f370d3cd3435b501
|
||||||
PKG_SOURCE_VERSION:=a872fc2f86
|
PKG_SOURCE_VERSION:=afacb8b7f0 # SHA1 used within the docker executables
|
||||||
|
|
||||||
PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>
|
PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>
|
||||||
|
|
||||||
@ -22,9 +22,9 @@ define CheckExpectedSrcVer
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
# values from respective '.installer' files at https://github.com/docker/docker-ce/blob/v$(PKG_VERSION)/components/engine/hack/dockerfile/install/
|
# values from respective '.installer' files at https://github.com/docker/docker-ce/blob/v$(PKG_VERSION)/components/engine/hack/dockerfile/install/
|
||||||
$(eval $(call CheckExpectedSrcVer,../containerd/Makefile,b34a5c8af56e510852c35414db4c1f4fa6172339))
|
$(eval $(call CheckExpectedSrcVer,../containerd/Makefile,7ad184331fa3e55e52b890ea95e65ba581ae3429))
|
||||||
$(eval $(call CheckExpectedSrcVer,../libnetwork/Makefile,45c710223c5fbf04dc3028b9a90b51892e36ca7f))
|
$(eval $(call CheckExpectedSrcVer,../libnetwork/Makefile,9fd385be8302dbe1071a3ce124891893ff27f90f))
|
||||||
$(eval $(call CheckExpectedSrcVer,../runc/Makefile,3e425f80a8c931f88e6d94a8c831b9d5aa481657))
|
$(eval $(call CheckExpectedSrcVer,../runc/Makefile,dc9208a3303feef5b3839f4323d9beb36df0a9dd))
|
||||||
$(eval $(call CheckExpectedSrcVer,../tini/Makefile,fec3683b971d9c3ef73f284f176672c44b448662))
|
$(eval $(call CheckExpectedSrcVer,../tini/Makefile,fec3683b971d9c3ef73f284f176672c44b448662))
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=golang/host
|
PKG_BUILD_DEPENDS:=golang/host
|
||||||
@ -44,11 +44,10 @@ define Package/docker-ce
|
|||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
TITLE:=Docker Community Edition
|
TITLE:=Docker Community Edition
|
||||||
URL:=https://www.docker.com/
|
URL:=https://www.docker.com/
|
||||||
DEPENDS:=$(GO_ARCH_DEPENDS) @HAS_FPU @TARGET_x86_64||arm||aarch64 +btrfs-progs +ca-certificates +cgroupfs-mount +containerd +libdevmapper +libnetwork +tini \
|
DEPENDS:=$(GO_ARCH_DEPENDS) @(aarch64||arm||x86_64) +btrfs-progs +ca-certificates +cgroupfs-mount +containerd +libdevmapper +libnetwork +tini \
|
||||||
+DOCKER_SECCOMP:libseccomp +iptables-mod-extra +kmod-br-netfilter +kmod-ikconfig +kmod-nf-conntrack-netlink +kmod-nf-ipvs +kmod-veth \
|
+DOCKER_SECCOMP:libseccomp +iptables-mod-extra +kmod-br-netfilter +kmod-ikconfig +kmod-nf-conntrack-netlink +kmod-nf-ipvs +kmod-veth
|
||||||
+@KERNEL_CGROUPS +@KERNEL_CGROUP_CPUACCT +@KERNEL_CGROUP_SCHED
|
|
||||||
USERID:=docker:docker
|
USERID:=docker:docker
|
||||||
|
MENU:=1
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/docker-ce/description
|
define Package/docker-ce/description
|
||||||
@ -79,13 +78,7 @@ endif
|
|||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
( \
|
( \
|
||||||
export GOPATH=$(GO_PKG_BUILD_DIR) \
|
export $(call GoPackage/Environment) \
|
||||||
GOCACHE=$(GO_PKG_CACHE_DIR) \
|
|
||||||
GOTMPDIR=$(GO_PKG_TMP_DIR) \
|
|
||||||
GOROOT_FINAL=$(GO_TARGET_ROOT) \
|
|
||||||
CC=$(TARGET_CC) \
|
|
||||||
CXX=$(TARGET_CXX) \
|
|
||||||
$(call GoPackage/Environment) \
|
|
||||||
GITCOMMIT=$(PKG_SOURCE_VERSION) \
|
GITCOMMIT=$(PKG_SOURCE_VERSION) \
|
||||||
DOCKER_GITCOMMIT=$(PKG_SOURCE_VERSION) \
|
DOCKER_GITCOMMIT=$(PKG_SOURCE_VERSION) \
|
||||||
DOCKER_BUILDTAGS='$(BUILDTAGS)' \
|
DOCKER_BUILDTAGS='$(BUILDTAGS)' \
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
Index: docker-ce-18.09.0/components/engine/hack/make/.binary
|
|
||||||
===================================================================
|
|
||||||
--- a/components/engine/hack/make/.binary
|
|
||||||
+++ b/components/engine/hack/make/.binary
|
|
||||||
@@ -54,17 +54,17 @@
|
|
||||||
export CGO_ENABLED=1
|
|
||||||
;;
|
|
||||||
7)
|
|
||||||
- export CC=arm-linux-gnueabihf-gcc
|
|
||||||
+ export CC=arm-openwrt-linux-gcc
|
|
||||||
export CGO_ENABLED=1
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
;;
|
|
||||||
linux/arm64)
|
|
||||||
- export CC=aarch64-linux-gnu-gcc
|
|
||||||
+ export CC=aarch64-openwrt-linux-gcc
|
|
||||||
export CGO_ENABLED=1
|
|
||||||
;;
|
|
||||||
linux/amd64)
|
|
||||||
- export CC=x86_64-linux-gnu-gcc
|
|
||||||
+ export CC=x86_64-openwrt-linux-gcc
|
|
||||||
export CGO_ENABLED=1
|
|
||||||
;;
|
|
||||||
esac
|
|
@ -0,0 +1,58 @@
|
|||||||
|
From 2fdfb4404ab811cb00227a3de111437b829e55cf Mon Sep 17 00:00:00 2001
|
||||||
|
From: Hongxu Jia <hongxu.jia@windriver.com>
|
||||||
|
Date: Wed, 17 Jul 2019 17:34:04 +0800
|
||||||
|
Subject: [PATCH] imporve hardcoded CC on cross compile
|
||||||
|
|
||||||
|
Since commit applied in moby [61a3285 Support cross-compile for arm]
|
||||||
|
it hardcoded var-CC to support cross-compile for arm
|
||||||
|
|
||||||
|
Correct it with "${parameter:-word}" format, it is helpful for user
|
||||||
|
define toolchains
|
||||||
|
|
||||||
|
(Use Default Values. If parameter is unset or null, the expansion of
|
||||||
|
word is substituted. Otherwise, the value of parameter is substituted.)
|
||||||
|
|
||||||
|
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
|
||||||
|
Upstream-commit: 3c701e4db1b8646c2324ae524b4e7ca1b1147a07
|
||||||
|
Component: engine
|
||||||
|
---
|
||||||
|
components/engine/hack/make/.binary | 10 +++++-----
|
||||||
|
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/components/engine/hack/make/.binary b/components/engine/hack/make/.binary
|
||||||
|
index 53de6749e5..66f4ca05f3 100644
|
||||||
|
--- a/components/engine/hack/make/.binary
|
||||||
|
+++ b/components/engine/hack/make/.binary
|
||||||
|
@@ -44,27 +44,27 @@ if [ "$(go env GOOS)/$(go env GOARCH)" != "$(go env GOHOSTOS)/$(go env GOHOSTARC
|
||||||
|
# must be cross-compiling!
|
||||||
|
case "$(go env GOOS)/$(go env GOARCH)" in
|
||||||
|
windows/amd64)
|
||||||
|
- export CC=x86_64-w64-mingw32-gcc
|
||||||
|
+ export CC="${CC:-x86_64-w64-mingw32-gcc}"
|
||||||
|
export CGO_ENABLED=1
|
||||||
|
;;
|
||||||
|
linux/arm)
|
||||||
|
case "${GOARM}" in
|
||||||
|
5|"")
|
||||||
|
- export CC=arm-linux-gnueabi-gcc
|
||||||
|
+ export CC="${CC:-arm-linux-gnueabi-gcc}"
|
||||||
|
export CGO_ENABLED=1
|
||||||
|
;;
|
||||||
|
7)
|
||||||
|
- export CC=arm-linux-gnueabihf-gcc
|
||||||
|
+ export CC="${CC:-arm-linux-gnueabihf-gcc}"
|
||||||
|
export CGO_ENABLED=1
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
;;
|
||||||
|
linux/arm64)
|
||||||
|
- export CC=aarch64-linux-gnu-gcc
|
||||||
|
+ export CC="${CC:-aarch64-linux-gnu-gcc}"
|
||||||
|
export CGO_ENABLED=1
|
||||||
|
;;
|
||||||
|
linux/amd64)
|
||||||
|
- export CC=x86_64-linux-gnu-gcc
|
||||||
|
+ export CC="${CC:-x86_64-linux-gnu-gcc}"
|
||||||
|
export CGO_ENABLED=1
|
||||||
|
;;
|
||||||
|
esac
|
Loading…
Reference in New Issue
Block a user