mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-04-30 23:30:10 +08:00
update netatalk_3.1.12 libgcrypt_1.8.5 libgpg-error_1.36 due to macOS auth error
This commit is contained in:
parent
ba94e9ce35
commit
c8b50f68c4
@ -8,16 +8,16 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libgcrypt
|
||||
PKG_VERSION:=1.6.6
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.8.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://www.gnupg.org/ftp/gcrypt/libgcrypt/
|
||||
PKG_HASH:=f9461b4619bb78b273a88d468915750d418e89a3ea3b641bab0563a9af4b04d0
|
||||
PKG_LICENSE:=LGPL-2.1+ GPL-2.0+
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_HASH:=3b4a2a94cb637eff5bdebbcaf46f4d95c4f25206f459809339cdada0eb577ac3
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_CPE_ID:=cpe:/a:gnupg:libgcrypt
|
||||
|
||||
PKG_FIXUP:=autoreconf patch-libtool
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
@ -28,8 +28,9 @@ define Package/libgcrypt
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libgpg-error
|
||||
TITLE:=GNU crypto library
|
||||
URL:=http://directory.fsf.org/security/libgcrypt.html
|
||||
MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
URL:=https://www.gnupg.org/related_software/libgcrypt/
|
||||
LICENSE:=LGPL-2.1-or-later
|
||||
LICENSE_FILES:=COPYING.LIB
|
||||
endef
|
||||
|
||||
define Package/libgcrypt/description
|
||||
@ -47,6 +48,7 @@ CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-asm \
|
||||
--disable-doc \
|
||||
--with-gpg-error-prefix="$(STAGING_DIR)/usr"
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
@ -1,28 +0,0 @@
|
||||
diff -u --recursive libgcrypt-1.6.1-vanilla/Makefile.am libgcrypt-1.6.1/Makefile.am
|
||||
--- libgcrypt-1.6.1-vanilla/Makefile.am 2014-07-18 00:31:21.020329371 -0400
|
||||
+++ libgcrypt-1.6.1/Makefile.am 2014-07-18 00:31:49.076314616 -0400
|
||||
@@ -25,8 +25,8 @@
|
||||
# (A suitable gitlog-to-changelog script can be found in GnuPG master.)
|
||||
GITLOG_TO_CHANGELOG=gitlog-to-changelog
|
||||
|
||||
-DIST_SUBDIRS = m4 compat mpi cipher random src doc tests
|
||||
-SUBDIRS = compat mpi cipher random src doc tests
|
||||
+DIST_SUBDIRS = m4 compat mpi cipher random src
|
||||
+SUBDIRS = compat mpi cipher random src
|
||||
|
||||
EXTRA_DIST = autogen.sh autogen.rc README.GIT LICENSES \
|
||||
ChangeLog-2011 build-aux/ChangeLog-2011 doc/ChangeLog-2011 \
|
||||
diff -u --recursive libgcrypt-1.6.1-vanilla/Makefile.in libgcrypt-1.6.1/Makefile.in
|
||||
--- libgcrypt-1.6.1-vanilla/Makefile.in 2014-07-18 00:31:21.020329371 -0400
|
||||
+++ libgcrypt-1.6.1/Makefile.in 2014-07-18 00:31:54.974311498 -0400
|
||||
@@ -331,8 +331,8 @@
|
||||
|
||||
# (A suitable gitlog-to-changelog script can be found in GnuPG master.)
|
||||
GITLOG_TO_CHANGELOG = gitlog-to-changelog
|
||||
-DIST_SUBDIRS = m4 compat mpi cipher random src doc tests
|
||||
-SUBDIRS = compat mpi cipher random src doc tests
|
||||
+DIST_SUBDIRS = m4 compat mpi cipher random src
|
||||
+SUBDIRS = compat mpi cipher random src
|
||||
EXTRA_DIST = autogen.sh autogen.rc README.GIT LICENSES \
|
||||
ChangeLog-2011 build-aux/ChangeLog-2011 doc/ChangeLog-2011 \
|
||||
m4/ChangeLog-2011 cipher/ChangeLog-2011 src/ChangeLog-2011 \
|
@ -1,43 +0,0 @@
|
||||
From a785cc3db0c4e8eb8ebbf784b833a40d2c42ec3e Mon Sep 17 00:00:00 2001
|
||||
From: Werner Koch <wk@gnupg.org>
|
||||
Date: Tue, 25 Aug 2015 21:11:05 +0200
|
||||
Subject: [PATCH] Add configure option --enable-build-timestamp.
|
||||
|
||||
* configure.ac (BUILD_TIMESTAMP): Set to "<none>" by default.
|
||||
--
|
||||
|
||||
This is based on
|
||||
libgpg-error commit d620005fd1a655d591fccb44639e22ea445e4554
|
||||
but changed to be disabled by default. Check there for some
|
||||
background.
|
||||
|
||||
Signed-off-by: Werner Koch <wk@gnupg.org>
|
||||
---
|
||||
configure.ac | 11 ++++++++++-
|
||||
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 48e217947287..2acfa3630cac 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2272,7 +2272,16 @@ changequote([,])dnl
|
||||
BUILD_FILEVERSION="${BUILD_FILEVERSION}mym4_revision_dec"
|
||||
AC_SUBST(BUILD_FILEVERSION)
|
||||
|
||||
-BUILD_TIMESTAMP=`date -u +%Y-%m-%dT%H:%M+0000 2>/dev/null || date`
|
||||
+AC_ARG_ENABLE([build-timestamp],
|
||||
+ AC_HELP_STRING([--enable-build-timestamp],
|
||||
+ [set an explicit build timestamp for reproducibility.
|
||||
+ (default is the current time in ISO-8601 format)]),
|
||||
+ [if test "$enableval" = "yes"; then
|
||||
+ BUILD_TIMESTAMP=`date -u +%Y-%m-%dT%H:%M+0000 2>/dev/null || date`
|
||||
+ else
|
||||
+ BUILD_TIMESTAMP="$enableval"
|
||||
+ fi],
|
||||
+ [BUILD_TIMESTAMP="<none>"])
|
||||
AC_SUBST(BUILD_TIMESTAMP)
|
||||
AC_DEFINE_UNQUOTED(BUILD_TIMESTAMP, "$BUILD_TIMESTAMP",
|
||||
[The time this package was configured for a build])
|
||||
--
|
||||
2.15.1
|
||||
|
@ -8,17 +8,22 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libgpg-error
|
||||
PKG_VERSION:=1.12
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=1.36
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgpg-error
|
||||
PKG_HASH:=cafc9ed6a87c53a35175d5a1220a96ca386696eef2fa059cc0306211f246e55f
|
||||
PKG_LICENSE:=LGPL-2.1+
|
||||
PKG_SOURCE_URL:=https://mirrors.dotsrc.org/gcrypt/libgpg-error \
|
||||
http://ring.ksc.gr.jp/archives/net/gnupg/libgpg-error \
|
||||
https://www.gnupg.org/ftp/gcrypt/libgpg-error
|
||||
PKG_HASH:=babd98437208c163175c29453f8681094bcaf92968a15cafb1a276076b33c97c
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -26,8 +31,7 @@ define Package/libgpg-error
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=GnuPG error handling helper library
|
||||
URL:=http://www.gnupg.org/related_software/libgpg-error/
|
||||
MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
URL:=https://www.gnupg.org/related_software/libgpg-error/
|
||||
endef
|
||||
|
||||
define Package/libgpg-error/description
|
||||
@ -38,12 +42,13 @@ define Package/libgpg-error/description
|
||||
future.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath
|
||||
--disable-doc \
|
||||
--disable-languages \
|
||||
--disable-rpath \
|
||||
--disable-tests
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(2)/bin $(1)/usr/bin
|
||||
|
24
libs/libgpg-error/patches/001-cross-compile-fix.patch
Normal file
24
libs/libgpg-error/patches/001-cross-compile-fix.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -74,6 +74,21 @@ AM_SILENT_RULES
|
||||
AC_CANONICAL_HOST
|
||||
AB_INIT
|
||||
|
||||
+case "${host}" in
|
||||
+ x86_64-openwrt-linux-gnu|i?86-openwrt-linux-gnu)
|
||||
+ host=$(echo $host | sed 's/openwrt/pc/g')
|
||||
+ ;;
|
||||
+ arm-openwrt-linux-gnu|armeb-openwrt-linux-gnu)
|
||||
+ host=arm-unknown-linux-gnueabi
|
||||
+ ;;
|
||||
+ mips64-openwrt-linux-gnu)
|
||||
+ host=mips64el-unknown-linux-gnuabi64
|
||||
+ ;;
|
||||
+ *)
|
||||
+ host=$(echo $host | sed 's/openwrt/unknown/g')
|
||||
+ ;;
|
||||
+esac
|
||||
+
|
||||
# Checks for programs.
|
||||
AC_PROG_CC
|
||||
AM_PROG_CC_C_O
|
@ -1,54 +0,0 @@
|
||||
From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
|
||||
Date: Mon, 16 Mar 2015 17:40:12 +0000 (-0400)
|
||||
Subject: Avoid breakage with gcc 5
|
||||
X-Git-Tag: libgpg-error-1.19~7
|
||||
X-Git-Url: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgpg-error.git;a=commitdiff_plain;h=c01c8f0c4f55d76b037c7f6aa44ad25ede18d38a
|
||||
|
||||
Avoid breakage with gcc 5
|
||||
|
||||
* src/Makefile.am: Add -P to the C preprocessor when building
|
||||
mkerrcodes.h, to avoid a noisy intermediate pipeline.
|
||||
|
||||
--
|
||||
|
||||
With gcc 5 without this patch, we see many errors like the following:
|
||||
|
||||
gcc -I. -I. -o mkerrcodes ./mkerrcodes.c
|
||||
In file included from ./mkerrcodes.c:26:0:
|
||||
./mkerrcodes.h:9:5: error: expected expression before ‘,’ token
|
||||
{ , "GPG_ERR_E2BIG" },
|
||||
^
|
||||
./mkerrcodes.h:10:5: error: expected expression before ‘,’ token
|
||||
{ , "GPG_ERR_EACCES" },
|
||||
^
|
||||
|
||||
This patch cleans up the generated mkerrcodes.h by making the
|
||||
intermediate stage clean for all the versions of gcc i tested (4.x and
|
||||
5).
|
||||
|
||||
Debian-Bug-Id: 777374
|
||||
Signed-Off-By: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
|
||||
---
|
||||
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -140,7 +140,7 @@ code-to-errno.h: Makefile mkerrnos.awk e
|
||||
# It is correct to use $(CPP). We want the host's idea of the error codes.
|
||||
mkerrcodes.h: Makefile mkerrcodes.awk $(gpg_extra_headers)
|
||||
$(AWK) -f $(srcdir)/mkerrcodes1.awk $(srcdir)/errnos.in >_$@
|
||||
- $(CPP) $(CPPFLAGS) $(extra_cppflags) _$@ | grep GPG_ERR_ | \
|
||||
+ $(CPP) $(CPPFLAGS) $(extra_cppflags) -P _$@ | grep GPG_ERR_ | \
|
||||
$(AWK) -f $(srcdir)/mkerrcodes.awk >$@
|
||||
-rm _$@
|
||||
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -979,7 +979,7 @@ code-to-errno.h: Makefile mkerrnos.awk e
|
||||
# It is correct to use $(CPP). We want the host's idea of the error codes.
|
||||
mkerrcodes.h: Makefile mkerrcodes.awk $(gpg_extra_headers)
|
||||
$(AWK) -f $(srcdir)/mkerrcodes1.awk $(srcdir)/errnos.in >_$@
|
||||
- $(CPP) $(CPPFLAGS) $(extra_cppflags) _$@ | grep GPG_ERR_ | \
|
||||
+ $(CPP) $(CPPFLAGS) $(extra_cppflags) -P _$@ | grep GPG_ERR_ | \
|
||||
$(AWK) -f $(srcdir)/mkerrcodes.awk >$@
|
||||
-rm _$@
|
||||
|
71
libs/libgpg-error/patches/010-add-arc-support.patch
Normal file
71
libs/libgpg-error/patches/010-add-arc-support.patch
Normal file
@ -0,0 +1,71 @@
|
||||
From: Mylene Josserand <mylene.josserand at bootlin.com>
|
||||
|
||||
DesignWare ARC Processors are a family of 32-bit CPUs from Synopsys.
|
||||
This change allows us to build for and use libgpg-error on ARC cores.
|
||||
|
||||
These values were obtained from a test application executed on ARC
|
||||
in simulation this way:
|
||||
|
||||
1. Instructions for cross-compilation used are here:
|
||||
http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgpg-error.git;a=blob;f=README
|
||||
|
||||
2. Commands used on host:
|
||||
# build="$(build-aux/config.guess)"
|
||||
# ./configure --prefix=build/tmp-uclibc/sysroots/nsimhs/usr/ --host=arc-oe-linux-uclibc --build=$build
|
||||
# cd src
|
||||
# make gen-posix-lock-obj
|
||||
|
||||
3. Commands used on target:
|
||||
# ./gen-posix-lock-obj
|
||||
|
||||
Signed-off-by: Mylene Josserand <mylene.josserand at bootlin.com>
|
||||
Signed-off-by: Alexey Brodkin <abrodkin at synopsys.com>
|
||||
---
|
||||
src/Makefile.am | 1 +
|
||||
.../lock-obj-pub.arc-unknown-linux-gnu.h | 23 +++++++++++++++++++
|
||||
2 files changed, 24 insertions(+)
|
||||
create mode 100644 src/syscfg/lock-obj-pub.arc-unknown-linux-gnu.h
|
||||
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index 380ea7c09c04..bd00961c2f27 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -48,6 +48,7 @@ lock_obj_pub = \
|
||||
syscfg/lock-obj-pub.aarch64-unknown-linux-gnu_ilp32.h \
|
||||
syscfg/lock-obj-pub.aarch64-apple-darwin.h \
|
||||
syscfg/lock-obj-pub.alpha-unknown-linux-gnu.h \
|
||||
+ syscfg/lock-obj-pub.arc-unknown-linux-gnu.h \
|
||||
syscfg/lock-obj-pub.arm-unknown-linux-androideabi.h \
|
||||
syscfg/lock-obj-pub.arm-unknown-linux-gnueabi.h \
|
||||
syscfg/lock-obj-pub.arm-apple-darwin.h \
|
||||
diff --git a/src/syscfg/lock-obj-pub.arc-unknown-linux-gnu.h b/src/syscfg/lock-obj-pub.arc-unknown-linux-gnu.h
|
||||
new file mode 100644
|
||||
index 000000000000..3b1a8fadf8a7
|
||||
--- /dev/null
|
||||
+++ b/src/syscfg/lock-obj-pub.arc-unknown-linux-gnu.h
|
||||
@@ -0,0 +1,23 @@
|
||||
+## lock-obj-pub.arc-oe-linux-uclibc.h
|
||||
+## File created by gen-posix-lock-obj - DO NOT EDIT
|
||||
+## To be included by mkheader into gpg-error.h
|
||||
+
|
||||
+typedef struct
|
||||
+{
|
||||
+ long _vers;
|
||||
+ union {
|
||||
+ volatile char _priv[24];
|
||||
+ long _x_align;
|
||||
+ long *_xp_align;
|
||||
+ } u;
|
||||
+} gpgrt_lock_t;
|
||||
+
|
||||
+#define GPGRT_LOCK_INITIALIZER {1,{{0,0,0,0,0,0,0,0, \
|
||||
+ 0,0,0,0,0,0,0,0, \
|
||||
+ 0,0,0,0,0,0,0,0}}}
|
||||
+##
|
||||
+## Local Variables:
|
||||
+## mode: c
|
||||
+## buffer-read-only: t
|
||||
+## End:
|
||||
+##
|
||||
--
|
||||
2.17.1
|
158
libs/libgpg-error/patches/020-gawk5-support.patch
Normal file
158
libs/libgpg-error/patches/020-gawk5-support.patch
Normal file
@ -0,0 +1,158 @@
|
||||
From 7865041c77f4f7005282f10f9b6666b19072fbdf Mon Sep 17 00:00:00 2001
|
||||
From: NIIBE Yutaka <gniibe@fsij.org>
|
||||
Date: Mon, 15 Apr 2019 15:10:44 +0900
|
||||
Subject: [PATCH] awk: Prepare for Gawk 5.0.
|
||||
|
||||
* src/Makefile.am: Use pkg_namespace (instead of namespace).
|
||||
* src/mkerrnos.awk: Likewise.
|
||||
* lang/cl/mkerrcodes.awk: Don't escape # in regexp.
|
||||
* src/mkerrcodes.awk, src/mkerrcodes1.awk, src/mkerrcodes2.awk: Ditto.
|
||||
|
||||
--
|
||||
|
||||
In Gawk 5.0, regexp routines are replaced by Gnulib implementation,
|
||||
which only allows escaping specific characters.
|
||||
|
||||
GnuPG-bug-id: 4459
|
||||
Reported-by: Marius Schamschula
|
||||
Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
|
||||
---
|
||||
lang/cl/mkerrcodes.awk | 2 +-
|
||||
src/Makefile.am | 2 +-
|
||||
src/mkerrcodes.awk | 2 +-
|
||||
src/mkerrcodes1.awk | 2 +-
|
||||
src/mkerrcodes2.awk | 2 +-
|
||||
src/mkerrnos.awk | 2 +-
|
||||
src/mkstrtable.awk | 10 +++++-----
|
||||
7 files changed, 11 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/lang/cl/mkerrcodes.awk b/lang/cl/mkerrcodes.awk
|
||||
index ae29043..9a1fc18 100644
|
||||
--- a/lang/cl/mkerrcodes.awk
|
||||
+++ b/lang/cl/mkerrcodes.awk
|
||||
@@ -122,7 +122,7 @@ header {
|
||||
}
|
||||
|
||||
!header {
|
||||
- sub (/\#.+/, "");
|
||||
+ sub (/#.+/, "");
|
||||
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
|
||||
|
||||
if (/^$/)
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index ce1b882..f2590cb 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -293,7 +293,7 @@ code-from-errno.h: mkerrcodes$(EXEEXT_FOR_BUILD) Makefile
|
||||
|
||||
errnos-sym.h: Makefile mkstrtable.awk errnos.in
|
||||
$(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=2 -v nogettext=1 \
|
||||
- -v prefix=GPG_ERR_ -v namespace=errnos_ \
|
||||
+ -v prefix=GPG_ERR_ -v pkg_namespace=errnos_ \
|
||||
$(srcdir)/errnos.in >$@
|
||||
|
||||
|
||||
diff --git a/src/mkerrcodes.awk b/src/mkerrcodes.awk
|
||||
index 46d436c..e9c857c 100644
|
||||
--- a/src/mkerrcodes.awk
|
||||
+++ b/src/mkerrcodes.awk
|
||||
@@ -85,7 +85,7 @@ header {
|
||||
}
|
||||
|
||||
!header {
|
||||
- sub (/\#.+/, "");
|
||||
+ sub (/#.+/, "");
|
||||
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
|
||||
|
||||
if (/^$/)
|
||||
diff --git a/src/mkerrcodes1.awk b/src/mkerrcodes1.awk
|
||||
index a771a73..4578e29 100644
|
||||
--- a/src/mkerrcodes1.awk
|
||||
+++ b/src/mkerrcodes1.awk
|
||||
@@ -81,7 +81,7 @@ header {
|
||||
}
|
||||
|
||||
!header {
|
||||
- sub (/\#.+/, "");
|
||||
+ sub (/#.+/, "");
|
||||
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
|
||||
|
||||
if (/^$/)
|
||||
diff --git a/src/mkerrcodes2.awk b/src/mkerrcodes2.awk
|
||||
index ea58503..188f7a4 100644
|
||||
--- a/src/mkerrcodes2.awk
|
||||
+++ b/src/mkerrcodes2.awk
|
||||
@@ -91,7 +91,7 @@ header {
|
||||
}
|
||||
|
||||
!header {
|
||||
- sub (/\#.+/, "");
|
||||
+ sub (/#.+/, "");
|
||||
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
|
||||
|
||||
if (/^$/)
|
||||
diff --git a/src/mkerrnos.awk b/src/mkerrnos.awk
|
||||
index f79df66..15b1aad 100644
|
||||
--- a/src/mkerrnos.awk
|
||||
+++ b/src/mkerrnos.awk
|
||||
@@ -83,7 +83,7 @@ header {
|
||||
}
|
||||
|
||||
!header {
|
||||
- sub (/\#.+/, "");
|
||||
+ sub (/#.+/, "");
|
||||
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
|
||||
|
||||
if (/^$/)
|
||||
diff --git a/src/mkstrtable.awk b/src/mkstrtable.awk
|
||||
index c9de9c1..285e45f 100644
|
||||
--- a/src/mkstrtable.awk
|
||||
+++ b/src/mkstrtable.awk
|
||||
@@ -77,7 +77,7 @@
|
||||
#
|
||||
# The variable prefix can be used to prepend a string to each message.
|
||||
#
|
||||
-# The variable namespace can be used to prepend a string to each
|
||||
+# The variable pkg_namespace can be used to prepend a string to each
|
||||
# variable and macro name.
|
||||
|
||||
BEGIN {
|
||||
@@ -102,7 +102,7 @@ header {
|
||||
print "/* The purpose of this complex string table is to produce";
|
||||
print " optimal code with a minimum of relocations. */";
|
||||
print "";
|
||||
- print "static const char " namespace "msgstr[] = ";
|
||||
+ print "static const char " pkg_namespace "msgstr[] = ";
|
||||
header = 0;
|
||||
}
|
||||
else
|
||||
@@ -110,7 +110,7 @@ header {
|
||||
}
|
||||
|
||||
!header {
|
||||
- sub (/\#.+/, "");
|
||||
+ sub (/#.+/, "");
|
||||
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
|
||||
|
||||
if (/^$/)
|
||||
@@ -150,7 +150,7 @@ END {
|
||||
else
|
||||
print " gettext_noop (\"" last_msgstr "\");";
|
||||
print "";
|
||||
- print "static const int " namespace "msgidx[] =";
|
||||
+ print "static const int " pkg_namespace "msgidx[] =";
|
||||
print " {";
|
||||
for (i = 0; i < coded_msgs; i++)
|
||||
print " " pos[i] ",";
|
||||
@@ -158,7 +158,7 @@ END {
|
||||
print " };";
|
||||
print "";
|
||||
print "static GPG_ERR_INLINE int";
|
||||
- print namespace "msgidxof (int code)";
|
||||
+ print pkg_namespace "msgidxof (int code)";
|
||||
print "{";
|
||||
print " return (0 ? 0";
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
@ -8,24 +8,26 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=netatalk
|
||||
PKG_VERSION:=3.1.11
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=3.1.12
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/netatalk
|
||||
PKG_HASH:=3434472ba96d3bbe3b024274438daad83b784ced720f7662a4c1d0a1078799a6
|
||||
PKG_HASH:=1560f83a3da41be97e0b70a96e2402159b8ddc631d38538360b14784beada5d1
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
PKG_BUILD_DEPENDS:=libevent2
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/netatalk
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=Filesystem
|
||||
DEPENDS:=+libattr +libdb47 +libgcrypt +libopenssl $(LIBRPC_DEPENDS)
|
||||
DEPENDS:=+libattr +libdb47 +libgcrypt +libopenssl
|
||||
TITLE:=netatalk
|
||||
URL:=http://netatalk.sourceforge.net
|
||||
MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
|
||||
@ -38,7 +40,6 @@ define Package/netatalk/decription
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -std=gnu99
|
||||
TARGET_LDFLAGS += $(LIBRPC)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-afs \
|
||||
@ -51,6 +52,7 @@ CONFIGURE_ARGS += \
|
||||
--disable-tcp-wrappers \
|
||||
--with-cnid-default-backend=dbd \
|
||||
--with-bdb="$(STAGING_DIR)/usr/" \
|
||||
--with-libevent=no \
|
||||
--with-libgcrypt-dir="$(STAGING_DIR)/usr" \
|
||||
--with-ssl-dir="$(STAGING_DIR)/usr" \
|
||||
--with-uams-path="/usr/lib/uams" \
|
||||
|
Loading…
Reference in New Issue
Block a user