mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 05:21:46 +08:00
sync upstream source code
This commit is contained in:
parent
6cb66c4343
commit
c86ac7adc6
@ -10,12 +10,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=haproxy
|
||||
PKG_VERSION:=2.2.4
|
||||
PKG_VERSION:=2.2.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.haproxy.org/download/2.2/src
|
||||
PKG_HASH:=87a4d9d4ff8dc3094cb61bbed4a8eed2c40b5ac47b9604daebaf036d7b541be2
|
||||
PKG_HASH:=be1c6754cbaceafc4837e0c6036c7f81027a3992516435cbbbc5dc749bf5a087
|
||||
|
||||
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>, \
|
||||
Christian Lachner <gladiac@gmail.com>
|
||||
|
@ -6,8 +6,6 @@ STOP=80
|
||||
|
||||
USE_PROCD=1
|
||||
|
||||
EXTRA_COMMANDS="check"
|
||||
|
||||
HAPROXY_BIN="/usr/sbin/haproxy"
|
||||
HAPROXY_CONFIG="/etc/haproxy.cfg"
|
||||
|
||||
@ -20,6 +18,7 @@ start_service() {
|
||||
procd_close_instance
|
||||
}
|
||||
|
||||
extra_command "check" "Check haproxy config"
|
||||
check() {
|
||||
$HAPROXY_BIN -c -q -V -f $HAPROXY_CONFIG
|
||||
}
|
||||
|
@ -1,7 +1,7 @@
|
||||
#!/bin/sh
|
||||
|
||||
CLONEURL=https://git.haproxy.org/git/haproxy-2.2.git
|
||||
BASE_TAG=v2.2.4
|
||||
BASE_TAG=v2.2.6
|
||||
TMP_REPODIR=tmprepo
|
||||
PATCHESDIR=patches
|
||||
|
||||
|
@ -1,23 +0,0 @@
|
||||
commit 62af9c83f9ed2b25e0061798e29e3cccfce5fbdc
|
||||
Author: Willy Tarreau <w@1wt.eu>
|
||||
Date: Tue Mar 10 07:51:48 2020 +0100
|
||||
|
||||
BUILD: make dladdr1 depend on glibc version and not __USE_GNU
|
||||
|
||||
Technically speaking the call was implemented in glibc 2.3 so we must
|
||||
rely on this and not on __USE_GNU which is an internal define of glibc
|
||||
to track use of GNU_SOURCE.
|
||||
|
||||
diff --git a/src/standard.c b/src/standard.c
|
||||
index e0ea8328e..d16eebfea 100644
|
||||
--- a/src/standard.c
|
||||
+++ b/src/standard.c
|
||||
@@ -4350,7 +4350,7 @@ void debug_hexdump(FILE *out, const char *pfx, const char *buf,
|
||||
static int dladdr_and_size(const void *addr, Dl_info *dli, size_t *size)
|
||||
{
|
||||
int ret;
|
||||
-#ifdef __USE_GNU // most detailed one
|
||||
+#if (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) // most detailed one
|
||||
const ElfW(Sym) *sym;
|
||||
|
||||
ret = dladdr1(addr, dli, (void **)&sym, RTLD_DL_SYMENT);
|
Loading…
Reference in New Issue
Block a user