This commit is contained in:
lean 2022-02-16 14:24:33 +08:00
commit b5e83ce6d1
16 changed files with 430 additions and 108 deletions

View File

@ -7,5 +7,5 @@
+#undef CONFIG_MODULE_STRIPPED
+
#include <linux/ctype.h>
#include <linux/version.h>
#include "unicode.h"

57
lang/cqueues/Makefile Normal file
View File

@ -0,0 +1,57 @@
#
# Copyright (C) 2022 Siger Yang <siger.yang@outlook.com>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=cqueues
PKG_VERSION:=20200726
PKG_RELEASE:=1
PKG_MAINTAINER:=Siger Yang <siger.yang@outlook.com>
PKG_MIRROR_HASH:=45bce9d3400f4c689d07ab3326610c2987424375dc575417eaafc6e5261b6009
PKG_SOURCE_URL:=https://github.com/wahern/cqueues.git
PKG_SOURCE_VERSION:=rel-$(PKG_VERSION)
PKG_SOURCE_PROTO:=git
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/cqueues
SUBMENU:=Lua
SECTION:=lang
CATEGORY:=Languages
TITLE:=lua cqueues
URL:=http://25thandclement.com/~william/projects/cqueues.html
DEPENDS:=+liblua +libopenssl
endef
define Package/cqueues/description
Continuation Queues: Embeddable asynchronous networking, threading, and
notification framework for Lua on Unix.
endef
TARGET_CFLAGS += $(FPIC)
TARGET_LDFLAGS += $(FPIC)
MAKE_FLAGS += \
LUA_APIS="5.1" \
lua51cpath="/usr/lib/lua" \
lua51path="/usr/lib/lua"
define Package/cqueues/install
$(INSTALL_DIR) $(1)/usr/lib/lua
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lua/_cqueues.so $(1)/usr/lib/lua/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/lua/cqueues.lua $(1)/usr/lib/lua/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lua/cqueues $(1)/usr/lib/lua/
endef
$(eval $(call BuildPackage,cqueues))

View File

@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
GO_VERSION_MAJOR_MINOR:=1.17
GO_VERSION_PATCH:=6
GO_VERSION_PATCH:=7
PKG_NAME:=golang
PKG_VERSION:=$(GO_VERSION_MAJOR_MINOR)$(if $(GO_VERSION_PATCH),.$(GO_VERSION_PATCH))
@ -20,7 +20,7 @@ GO_SOURCE_URLS:=https://dl.google.com/go/ \
PKG_SOURCE:=go$(PKG_VERSION).src.tar.gz
PKG_SOURCE_URL:=$(GO_SOURCE_URLS)
PKG_HASH:=4dc1bbf3ff61f0c1ff2b19355e6d88151a70126268a47c761477686ef94748c8
PKG_HASH:=c108cd33b73b1911a02b697741df3dea43e01a5c4e08e409e8b3a0e3745d2b4d
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
PKG_LICENSE:=BSD-3-Clause

View File

@ -2,7 +2,7 @@ This is https://github.com/golang/go/pull/49748 backported for Go 1.17.
--- a/src/cmd/link/internal/ld/lib.go
+++ b/src/cmd/link/internal/ld/lib.go
@@ -1388,23 +1388,18 @@ func (ctxt *Link) hostlink() {
@@ -1391,23 +1391,18 @@ func (ctxt *Link) hostlink() {
}
if ctxt.Arch.InFamily(sys.ARM, sys.ARM64) && buildcfg.GOOS == "linux" {

View File

@ -0,0 +1,78 @@
# SPDX-License-Identifier: MIT
#
# Copyright (C) 2021-2022 Gerald Kerma
#
include $(TOPDIR)/rules.mk
PKG_NAME:=lua-cs-bouncer
PKG_SOURCE_DATE:=2022-01-18
PKG_SOURCE_VERSION:=e0f68b1265c386715c1d6ab79fe9063c0a9e3d3a
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/crowdsecurity/$(PKG_NAME)/tar.gz/$(PKG_SOURCE_VERSION)?
PKG_HASH:=c7e92cc9dc023ebcd84f3632d6cf0e38a7d9f5e7bba15367247753a306b89829
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_SOURCE_VERSION)
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
PKG_MAINTAINER:=Gerald Kerma <gandalf@gk2.net>
HOST_BUILD_DEPENDS:=lua/host
PKG_BUILD_DEPENDS:=luarocks/host
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
define Package/lua-cs-bouncer
SUBMENU:=Lua
SECTION:=lang
CATEGORY:=Languages
TITLE:=Lua Crowdsec Bouncer module
URL:=https://github.com/crowdsecurity/lua-cs-bouncer
DEPENDS:=+lua \
+luasec
endef
define Package/lua-cs-bouncer/description
Lua module to allow ip (or not) from CrowdSec API.
endef
define Build/Compile
endef
define Package/lua-cs-bouncer/install
$(INSTALL_DIR) $(1)/usr/lib/lua/crowdsec
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/lib/*.lua \
$(1)/usr/lib/lua/crowdsec/
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/template.conf \
$(1)/usr/lib/lua/crowdsec/crowdsec.conf
$(INSTALL_DIR) $(1)/usr/lib/crowdsec/lua/plugins/crowdsec
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/nginx/config.lua \
$(1)/usr/lib/crowdsec/lua/plugins/crowdsec/
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/nginx/crowdsec.lua \
$(1)/usr/lib/crowdsec/lua/
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/nginx/recaptcha.lua \
$(1)/usr/lib/crowdsec/lua/
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/nginx/access.lua \
$(1)/usr/lib/crowdsec/lua/
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) \
./files/lua-cs-bouncer.defaults \
$(1)/etc/uci-defaults/99_lua-cs-bouncer
endef
define Package/lua-cs-bouncer/conffiles
/usr/lib/lua/crowdsec/crowdsec.conf
endef
$(eval $(call BuildPackage,lua-cs-bouncer))

View File

@ -0,0 +1,13 @@
#!/bin/sh
CONFIG=/usr/lib/lua/crowdsec/crowdsec.conf
## Gen&ConfigApiKey
if grep -q "{API_KEY}" "$CONFIG"; then
SUFFIX=`tr -dc A-Za-z0-9 </dev/urandom | head -c 8`
API_KEY=`/usr/bin/cscli bouncers add lua-cs-bouncer-${SUFFIX} -o raw`
sed -i "s,^\(\s*API_KEY\s*=\s*\).*\$,\1$API_KEY," $CONFIG
else
echo API key already registered...
fi
exit 0

View File

@ -1,97 +0,0 @@
#
# Copyright (C) 2016-2019 Yousong Zhou <yszhou4tech@gmail.com>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=dtc
PKG_VERSION:=1.6.1
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_HASH:=65cec529893659a49a89740bb362f507a3b94fc8cd791e76a8d6a2b6f3203473
PKG_SOURCE_URL:=@KERNEL/software/utils/dtc
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=GPL
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/dtc
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Device Tree Compiler
URL:=https://git.kernel.org/pub/scm/utils/dtc/dtc.git
endef
define Package/dtc/description
Device Tree Compiler for Flat Device Trees Device Tree Compiler, dtc, takes
as input a device-tree in a given format and outputs a device-tree in another
format for booting kernels on embedded systems.
endef
define Package/dtc/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/bin/dtc $(1)/usr/bin
endef
# See Documentation/manual.txt for details about each utility
define Package/fdt-utils
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Flat Device Tree Utilities
URL:=https://git.kernel.org/pub/scm/utils/dtc/dtc.git
DEPENDS:=+libfdt
endef
define Package/fdt-utils/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/convert-dtsv0 $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/fdtdump $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/fdtget $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/fdtput $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/fdtoverlay $(1)/usr/bin
endef
define Package/libfdt
SECTION:=libs
CATEGORY:=Libraries
TITLE:=a utility library for reading and manipulating dtb files
URL:=https://git.kernel.org/pub/scm/utils/dtc/dtc.git
endef
define Package/libfdt/description
This is a library containing functions for manipulating Flat Device Trees.
endef
define Package/libfdt/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/lib/libfdt*.so* $(1)/usr/lib
endef
# NO_PYTHON is for disabling pylibfdt
MAKE_FLAGS += \
PREFIX= \
NO_PYTHON=1 \
NO_VALGRIND=1 \
NO_YAML=1 \
EXTRA_CFLAGS=$(EXTRA_CFLAGS) \
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/include/* $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/lib/* $(1)/usr/lib
endef
$(eval $(call BuildPackage,dtc))
$(eval $(call BuildPackage,fdt-utils))
$(eval $(call BuildPackage,libfdt))

View File

@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ksmbd-tools
PKG_VERSION:=3.4.2
PKG_VERSION:=3.4.4
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/cifsd-team/ksmbd-tools/tar.gz/$(PKG_VERSION)?
PKG_HASH:=fb79bf9201321adb33f8a5f0a12bd205a86b2d4bb057a9f98e0e9521664c2bcd
PKG_HASH:=cc7cc2fcbeed052176894a8dbbf290919c3735b320401c6492cf17f1ba1a3548
PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later

View File

@ -5,12 +5,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mosdns
PKG_VERSION:=3.1.1
PKG_VERSION:=3.2.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/IrineSistiana/mosdns/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=a863848d7520b486b467b56b413a357e7aa3537c803ab51f5e65454deaec8f51
PKG_HASH:=72815c97e7dbbbd508d6f56a80a4dfdb0db70ed8b11de2a457a3eb1ec61fa15a
PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILE:=LICENSE

View File

@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=btrfs-progs
PKG_VERSION:=5.11
PKG_RELEASE:=1
PKG_VERSION:=5.16.1
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/kdave/btrfs-progs
PKG_HASH:=d41961b0a92160c80f894ad9a1882822889c2e1d084cbf3e08b8c214a5cf0137
PKG_HASH:=3da4da5361cf86bddda80edb4c4f30ea076cb4ebec29904fa08afc930ef9e1a8
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
PKG_MAINTAINER:=Karel Kočí <karel.koci@nic.cz>
@ -21,6 +21,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=acl
PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
@ -65,6 +66,7 @@ CONFIGURE_ARGS += \
--disable-backtrace \
--disable-convert \
--disable-documentation \
--disable-libudev \
--disable-python
ifneq ($(CONFIG_BTRFS_PROGS_ZSTD),y)
CONFIGURE_ARGS += --disable-zstd

View File

@ -0,0 +1,51 @@
From a065c28f8d6c5785d9c3730cb62078b8dbb4dc91 Mon Sep 17 00:00:00 2001
From: W_Y_CPP <383152993@qq.com>
Date: Tue, 15 Feb 2022 22:40:18 -0500
Subject: [PATCH] improve autodetection of zoned mode
---
configure.ac | 26 ++++++++++++++++++++++++--
1 file changed, 24 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 26d8510..2b16249 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,10 +282,32 @@ AC_CHECK_HEADER(linux/blkzoned.h, [blkzoned_found=yes], [blkzoned_found=no])
AC_CHECK_MEMBER([struct blk_zone.capacity], [blkzoned_capacity=yes], [blkzoned_capacity=no], [[#include <linux/blkzoned.h>]])
AX_CHECK_DEFINE([linux/blkzoned.h], [BLKGETZONESZ], [blkzoned_getzonesz=yes], [blkzoned_getzonesz=no])
AC_ARG_ENABLE([zoned],
- AS_HELP_STRING([--disable-zoned], [disable zoned block device support]),
- [], [enable_zoned=$blkzoned_found]
+ AS_HELP_STRING([--disable-zoned], [disable zoned block device support (default: detect)]),
+ [], [enable_zoned=$blkzoned_capacity]
)
+# Autodetect zoned support
+AS_IF([test "x$enableval" = "x"], [
+ cansupportzoned=yes
+ if test "x$blkzoned_found" = xno; then
+ cansupportzoned=no
+ fi
+ if test "x$blkzoned_capacity" = xno; then
+ cansupportzoned=no
+ fi
+ if test "x$blkzoned_getzonesz" = xno; then
+ cansupportzoned=no
+ fi
+ if test "x$cansupportzoned" = xno; then
+ AC_MSG_NOTICE([insufficient support for zoned mode, cannot enable])
+ enable_zoned=no
+ else
+ enable_zoned=yes
+ fi
+])
+
+# Explicitly requested by --enable-zoned
+
AS_IF([test "x$enable_zoned" = xyes], [
if test "x$blkzoned_found" = xno; then
AC_MSG_ERROR([Couldn't find linux/blkzoned.h])
--
2.17.1

View File

@ -0,0 +1,14 @@
--- btrfs-progs-v5.16.1/kernel-shared/zoned.h.orig 2022-02-06 11:09:39.728318915 +0000
+++ btrfs-progs-v5.16.1/kernel-shared/zoned.h 2022-02-06 11:11:21.772323202 +0000
@@ -145,6 +145,11 @@ static inline int btrfs_reset_dev_zone(i
return 0;
}
+static inline bool zoned_profile_supported(u64 flags)
+{
+ return false;
+}
+
static inline bool zone_is_sequential(struct btrfs_zoned_device_info *zinfo,
u64 bytenr)
{

View File

@ -0,0 +1,43 @@
From b5159062f079d451f23d7f2a0e7d9e2f84934f94 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Sat, 29 Jan 2022 17:09:56 -0800
Subject: [PATCH] btrfs-progs: fix 64-bit mips and powerpc types
The kernel uses 'unsigned long' for u64 specifically for ppc64 and
mips64.
Remove asm/types.h include as it will get included properly later.
Fixe -Wformat warnings.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Signed-off-by: David Sterba <dsterba@suse.com>
---
cmds/receive-dump.c | 1 -
kerncompat.h | 5 +++++
2 files changed, 5 insertions(+), 1 deletion(-)
--- a/cmds/receive-dump.c
+++ b/cmds/receive-dump.c
@@ -31,7 +31,6 @@
#include <stdlib.h>
#include <time.h>
#include <ctype.h>
-#include <asm/types.h>
#include <uuid/uuid.h>
#include "common/utils.h"
#include "cmds/commands.h"
--- a/kerncompat.h
+++ b/kerncompat.h
@@ -19,6 +19,11 @@
#ifndef __KERNCOMPAT_H__
#define __KERNCOMPAT_H__
+#ifndef __SANE_USERSPACE_TYPES__
+/* For PPC64 to get LL64 types */
+#define __SANE_USERSPACE_TYPES__
+#endif
+
#include <stdio.h>
#include <stdlib.h>
#include <errno.h>

View File

@ -0,0 +1,53 @@
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=shared-mime-info
PKG_VERSION:=2.1
PKG_RELEASE:=1
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_SOURCE:=shared-mime-info-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://gitlab.freedesktop.org/xdg/$(PKG_NAME)/-/archive/$(PKG_VERSION)
PKG_HASH:=37df6475da31a8b5fc63a54ba0770a3eefa0a708b778cb6366dccee96393cb60
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/meson.mk
define Package/shared-mime-info
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+glib2 +libxml2
TITLE:=MIME-type information
URL:=https://freedesktop.org/wiki/Software/shared-mime-info/
endef
define Package/shared-mime-info/description
The shared-mime-info package contains a database of MIME types and their file extensions.
endef
define Package/shared-mime-info/install
$(INSTALL_DIR) $(1)/usr/bin/
$(CP) \
$(PKG_INSTALL_DIR)/usr/bin/* \
$(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/share/
$(CP) \
$(PKG_INSTALL_DIR)/usr/share/* \
$(1)/usr/share/
endef
define Package/shared-mime-info/postinst
#!/bin/sh
update-mime-database /usr/share/mime/
endef
$(eval $(call BuildPackage,shared-mime-info))

View File

@ -0,0 +1,75 @@
From 5a406b06792e26a83c7346b3c2443c0bd8d4cdb2 Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz@archlinux.org>
Date: Mon, 8 Nov 2021 18:22:47 -0500
Subject: [PATCH] migrate from custom itstool to builtin msgfmt for creating
translated XML
gettext upstream has supported this for a very long time (since 0.19.7
via commit b3c2a5a242c36fbbaa0c5b17f975d6c638598a23, released in 2015),
and itstool is (mostly) a legacy of the time before gettext had proper
support for these sorts of use cases.
This is similar to the state of intltool, which is described at
https://wiki.gnome.org/MigratingFromIntltoolToGettext
During the port from autotools to meson, the legacy use of itstool was
faithfully translated to meson in the only way possible: by jumping
through hoops to run ninja inside ninja in order to generate the .mo
files for itstool, because meson's i18n module used a flawed design and
there was no "real" target to create those files, only a .PHONY
run_target which other rules cannot depend on.
Although meson 0.60.0 added support for real targets for the built .mo
files, this changed the rules for output filenames, breaking the script.
But msgfmt does not care, and anyways comes with builtin meson functions
for convenient use with XML files. So let's take this opportunity to
drop legacy dependencies and use the modern, builtin tooling, which
fixes this bug as a side effect.
Fixes #170
---
.gitlab-ci.yml | 2 --
README.md | 2 +-
data/freedesktop_generate.sh | 12 ------------
data/meson.build | 16 +++++-----------
meson.build | 1 -
5 files changed, 6 insertions(+), 27 deletions(-)
delete mode 100755 data/freedesktop_generate.sh
--- a/data/meson.build
+++ b/data/meson.build
@@ -1,18 +1,12 @@
install_man('update-mime-database.1')
-freedesktop_org_xml = custom_target('freedesktop.org.xml',
- input : files(
- 'freedesktop.org.xml.in',
- 'its/shared-mime-info.its',
- 'its/shared-mime-info.loc',
- ),
+freedesktop_org_xml = i18n.merge_file(
+ input: 'freedesktop.org.xml.in',
output: 'freedesktop.org.xml',
- command: [
- find_program('freedesktop_generate.sh'),
- meson.source_root(),
- meson.build_root()
- ],
+ data_dirs: '.',
+ po_dir: '../po',
+ type: 'xml',
install: true,
install_dir: get_option('datadir') / 'mime' / 'packages',
)
--- a/meson.build
+++ b/meson.build
@@ -20,7 +20,6 @@ config.set_quoted('VERSION', meson.proje
###############################################################################
# Find tools
-itstool = find_program('itstool')
xmllint = find_program('xmllint')
xmlto = find_program('xmlto')

View File

@ -0,0 +1,33 @@
--- a/data/meson.build
+++ b/data/meson.build
@@ -15,15 +15,3 @@ install_data(
[ 'its/shared-mime-info.loc', 'its/shared-mime-info.its', ],
install_dir : get_option('datadir') / 'gettext/its'
)
-
-custom_target('shared-mime-info-spec-html',
- input : 'shared-mime-info-spec.xml',
- output: 'shared-mime-info-spec-html',
- command: [
- xmlto,
- '-o', '@OUTPUT@',
- 'html-nochunks',
- '@INPUT@',
- ],
- build_by_default: true,
-)
--- a/meson.build
+++ b/meson.build
@@ -18,12 +18,6 @@ config.set_quoted('PACKAGE', meson.proje
config.set_quoted('VERSION', meson.project_version())
###############################################################################
-# Find tools
-
-xmllint = find_program('xmllint')
-xmlto = find_program('xmlto')
-
-###############################################################################
# Find xdgmime
xdgmime = get_option('xdgmime-path') / 'src'