mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 04:39:06 +08:00
cmdpad: fix bad scanf format
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
d1ed99da1e
commit
a6fbf0e234
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=cmdpad
|
||||
PKG_VERSION:=0.0.3
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=6
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=@SF/cmdpad
|
||||
|
11
utils/cmdpad/patches/160-format.patch
Normal file
11
utils/cmdpad/patches/160-format.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/src/parse.c
|
||||
+++ b/src/parse.c
|
||||
@@ -257,7 +257,7 @@ int ParseCommand( char * pchCommandLine)
|
||||
|
||||
pchValue = strtok( pchValue, ",") ;
|
||||
d2printf( "Value is '%s'\n", pchValue) ;
|
||||
- if( (pchValue == NULL ) || ( sscanf( pchValue, "%d", &code) != 1) )
|
||||
+ if( (pchValue == NULL ) || ( sscanf( pchValue, "%hu", &code) != 1) )
|
||||
return -1 ;
|
||||
|
||||
pchValue = strtok( NULL, ",") ;
|
Loading…
Reference in New Issue
Block a user