mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 06:11:25 +08:00
ttyd update
This commit is contained in:
parent
806e47676c
commit
a1489e9133
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ttyd
|
||||
PKG_VERSION:=1.6.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.6.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/tsl0922/ttyd/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=d14740bc82be0d0760dd0a3c97acbcbde490412a4edc61edabe46d311b068f83
|
||||
PKG_HASH:=fd3256099e1cc5c470220cbfbb3ab2c7fa1f92232c503f583556a8965aa83bac
|
||||
|
||||
PKG_MAINTAINER:=Shuanglei Tao <tsl0922@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
|
@ -79,7 +79,7 @@ ttyd_instance()
|
||||
${ssl_cert:+-C $ssl_cert} \
|
||||
${ssl_key:+-K $ssl_key} \
|
||||
${ssl_ca:+-A $ssl_ca} \
|
||||
${debug:+-d}
|
||||
${debug:+-d $debug}
|
||||
config_list_foreach "$1" client_option "procd_append_param command -t"
|
||||
procd_append_param command $command
|
||||
procd_set_param stdout 1
|
||||
|
@ -1,14 +1,14 @@
|
||||
--- a/src/server.c
|
||||
+++ b/src/server.c
|
||||
@@ -6,6 +6,7 @@
|
||||
#include <getopt.h>
|
||||
#include <signal.h>
|
||||
@@ -10,6 +10,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <syslog.h>
|
||||
|
||||
#include <libwebsockets.h>
|
||||
#include <json.h>
|
||||
@@ -418,7 +419,8 @@ main(int argc, char **argv) {
|
||||
#include "utils.h"
|
||||
|
||||
@@ -478,7 +479,8 @@ int main(int argc, char **argv) {
|
||||
return -1;
|
||||
}
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user