mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 08:09:23 +08:00
commit
9e282d108b
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
include $(INCLUDE_DIR)/nls.mk
|
include $(INCLUDE_DIR)/nls.mk
|
||||||
|
|
||||||
PKG_NAME:=curl
|
PKG_NAME:=curl
|
||||||
PKG_VERSION:=8.6.0
|
PKG_VERSION:=8.11.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
@ -17,7 +17,7 @@ PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(subst .,_,
|
|||||||
https://dl.uxnr.de/mirror/curl/ \
|
https://dl.uxnr.de/mirror/curl/ \
|
||||||
https://curl.askapache.com/download/ \
|
https://curl.askapache.com/download/ \
|
||||||
https://curl.se/download/
|
https://curl.se/download/
|
||||||
PKG_HASH:=b4785f2d8877fa92c0e45d7155cf8cc6750dbda961f4b1a45bcbec990cf2fa9b
|
PKG_HASH:=e9773ad1dfa21aedbfe8e1ef24c9478fa780b1b3d4f763c98dd04629b5e43485
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
@ -1,20 +1,24 @@
|
|||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -135,7 +135,7 @@ CLEANFILES = $(VC14_LIBVCXPROJ) $(VC14_S
|
@@ -96,7 +96,7 @@ DISTCLEANFILES = buildinfo.txt
|
||||||
bin_SCRIPTS = curl-config
|
bin_SCRIPTS = curl-config
|
||||||
|
|
||||||
SUBDIRS = lib src
|
SUBDIRS = lib docs src scripts
|
||||||
-DIST_SUBDIRS = $(SUBDIRS) tests packages scripts include docs
|
-DIST_SUBDIRS = $(SUBDIRS) tests packages include docs
|
||||||
+DIST_SUBDIRS = $(SUBDIRS) packages include
|
+DIST_SUBDIRS = $(SUBDIRS) packages include
|
||||||
|
|
||||||
pkgconfigdir = $(libdir)/pkgconfig
|
pkgconfigdir = $(libdir)/pkgconfig
|
||||||
pkgconfig_DATA = libcurl.pc
|
pkgconfig_DATA = libcurl.pc
|
||||||
@@ -243,8 +243,6 @@ cygwinbin:
|
@@ -217,12 +217,9 @@ cygwinbin:
|
||||||
# We extend the standard install with a custom hook:
|
if BUILD_DOCS
|
||||||
install-data-hook:
|
install-data-hook:
|
||||||
(cd include && $(MAKE) install)
|
(cd include && $(MAKE) install)
|
||||||
- (cd docs && $(MAKE) install)
|
- (cd docs && $(MAKE) install)
|
||||||
- (cd docs/libcurl && $(MAKE) install)
|
- (cd docs/libcurl && $(MAKE) install)
|
||||||
|
else
|
||||||
|
install-data-hook:
|
||||||
|
(cd include && $(MAKE) install)
|
||||||
|
- (cd docs && $(MAKE) install)
|
||||||
|
endif
|
||||||
|
|
||||||
# We extend the standard uninstall with a custom hook:
|
# We extend the standard uninstall with a custom hook:
|
||||||
uninstall-hook:
|
|
||||||
|
Loading…
Reference in New Issue
Block a user