mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-04-30 22:09:50 +08:00
libpsl: use iconv dependency
Removed need for manual iconv handling. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
4b08b5467f
commit
91992b8cc6
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libpsl
|
||||
PKG_VERSION:=0.21.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/rockdaboot/libpsl/releases/download/$(PKG_VERSION)
|
||||
@ -38,8 +38,6 @@ MESON_ARGS += \
|
||||
-Druntime=libidn2 \
|
||||
-Dbuiltin=libidn2
|
||||
|
||||
TARGET_LDFLAGS += -liconv
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libpsl.h $(1)/usr/include/
|
||||
|
29
libs/libpsl/patches/020-iconv.patch
Normal file
29
libs/libpsl/patches/020-iconv.patch
Normal file
@ -0,0 +1,29 @@
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -20,6 +20,7 @@ libicu_dep = notfound
|
||||
libidn_dep = notfound
|
||||
libunistring = notfound
|
||||
networking_deps = notfound
|
||||
+libiconv_dep = notfound
|
||||
|
||||
# FIXME: Cleanup this when Meson gets 'feature-combo':
|
||||
# https://github.com/mesonbuild/meson/issues/4566
|
||||
@@ -86,6 +87,7 @@ endif
|
||||
if libidn2_dep.found() or libidn_dep.found()
|
||||
# Check for libunistring, we need it for psl_str_to_utf8lower()
|
||||
libunistring = cc.find_library('unistring')
|
||||
+ libiconv_dep = dependency('iconv')
|
||||
endif
|
||||
|
||||
if host_machine.system() == 'windows'
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -19,7 +19,7 @@ cargs = [
|
||||
libpsl = library('psl', sources, suffixes_dafsa_h,
|
||||
include_directories : [configinc, includedir],
|
||||
c_args : cargs,
|
||||
- dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps],
|
||||
+ dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps, libiconv_dep],
|
||||
version: lt_version,
|
||||
install: true,
|
||||
)
|
Loading…
Reference in New Issue
Block a user