mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 02:41:22 +08:00
openssh: update to 9.9p1
This commit is contained in:
parent
5d275f5e72
commit
74abe2d064
@ -8,13 +8,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openssh
|
||||
PKG_VERSION:=9.3p1
|
||||
PKG_VERSION:=9.9p1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
|
||||
https://ftp.spline.de/pub/OpenBSD/OpenSSH/portable/
|
||||
PKG_HASH:=e9baba7701a76a51f3d85a62c383a3c9dcd97fa900b859bc7db114c1868af8a8
|
||||
PKG_HASH:=b343fbcdbff87f15b1986e6e15d6d4fc9a7d36066be6b7fb507087ba8f966c02
|
||||
|
||||
PKG_LICENSE:=BSD ISC
|
||||
PKG_LICENSE_FILES:=LICENCE
|
||||
@ -229,6 +229,8 @@ define Package/openssh-server/install
|
||||
$(INSTALL_BIN) ./files/sshd.failsafe $(1)/lib/preinit/99_10_failsafe_sshd
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/sshd $(1)/usr/sbin/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/sshd-session $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/openssh-server-pam/install
|
||||
|
@ -0,0 +1,22 @@
|
||||
diff --git a/loginrec.c b/loginrec.c
|
||||
index 45f13dee8b1f..7b1818b86753 100644
|
||||
--- a/loginrec.c
|
||||
+++ b/loginrec.c
|
||||
@@ -614,7 +614,7 @@ line_abbrevname(char *dst, const char *src, int dstsize)
|
||||
** into account.
|
||||
**/
|
||||
|
||||
-#if defined(USE_UTMP) || defined (USE_WTMP) || defined (USE_LOGIN)
|
||||
+#if defined(USE_BTMP) || defined(USE_UTMP) || defined (USE_WTMP) || defined (USE_LOGIN)
|
||||
|
||||
/* build the utmp structure */
|
||||
void
|
||||
@@ -698,7 +698,7 @@ construct_utmp(struct logininfo *li,
|
||||
}
|
||||
# endif
|
||||
}
|
||||
-#endif /* USE_UTMP || USE_WTMP || USE_LOGIN */
|
||||
+#endif /* USE_BTMP || USE_UTMP || USE_WTMP || USE_LOGIN */
|
||||
|
||||
/**
|
||||
** utmpx utility functions
|
Loading…
Reference in New Issue
Block a user