mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-04-30 22:23:17 +08:00
hplip: add a patch to respect CFLAGS
* fixes build with PIE Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
This commit is contained in:
parent
b0d8960ee3
commit
688346b250
29
utils/hplip/patches/070-respect-cflags.patch
Normal file
29
utils/hplip/patches/070-respect-cflags.patch
Normal file
@ -0,0 +1,29 @@
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -632,14 +632,14 @@ if test "$class_driver" = "no" && test "
|
||||
fi
|
||||
fi
|
||||
|
||||
-SAVE_CPPFLAGS="$CPPFLAGS"
|
||||
+SAVE_CFLAGS="$CFLAGS"
|
||||
CFLAGS=`python-config --includes`
|
||||
-if [ $? -eq 0 ]
|
||||
+if test $? -eq 0
|
||||
then
|
||||
echo $FLAGS
|
||||
else
|
||||
CFLAGS=`python3-config --includes`
|
||||
- if [ $? -eq 0 ]
|
||||
+ if test $? -eq 0
|
||||
then
|
||||
echo $FLAGS
|
||||
fi
|
||||
@@ -659,7 +659,7 @@ if test "$class_driver" = "no" && test "
|
||||
AS_IF([test "x$FOUND_HEADER" != "xyes"],
|
||||
[AC_MSG_ERROR([cannot find python-devel support], 6)])
|
||||
fi
|
||||
-CFLAGS="$save_CFLAGS"
|
||||
+CFLAGS="$SAVE_CFLAGS"
|
||||
|
||||
if test "$hpijs_only_build" = "no" && test "$scan_build" = "yes" && test "$hpcups_only_build" = "no"; then
|
||||
AC_CHECK_LIB([sane], [sane_open], [LIBS="$LIBS"], [AC_MSG_ERROR([cannot find sane-backends-devel support (or --disable-scan-build)], 12)])
|
Loading…
Reference in New Issue
Block a user