mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 04:51:19 +08:00
jose: bump version
This commit is contained in:
parent
1751e355e0
commit
4af7819ff7
@ -19,10 +19,8 @@ PKG_MAINTAINER:=Tibor Dudlák <tibor.dudlak@gmail.com>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/libjose
|
||||
SECTION:=libs
|
||||
|
@ -5,12 +5,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nlohmannjson
|
||||
PKG_VERSION:=3.9.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=3.10.2
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/nlohmann/json/zip/v$(PKG_VERSION)?
|
||||
PKG_HASH:=a88449d68aab8d027c5beefe911ba217f5ffcc0686ae1793d37f3d20698b37c6
|
||||
PKG_HASH:=6e407a7a7a6fe2f20396270ed561afeda03cd238ccb32ad94b7f985b0aa113fe
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/json-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Leonid Esman <leonid.esman@gmail.com>
|
||||
@ -18,10 +18,9 @@ PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE.MIT
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/nlohmannjson
|
||||
SECTION:=libs
|
||||
|
@ -8,22 +8,21 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=p11-kit
|
||||
PKG_VERSION:=0.23.22
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=0.24.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/p11-glue/p11-kit/releases/download/$(PKG_VERSION)
|
||||
PKG_HASH:=8a8f40153dd5a3f8e7c03e641f8db400133fb2a6a9ab2aee1b6d0cb0495ec6b6
|
||||
PKG_HASH:=81e6140584f635e4e956a1b93a32239acf3811ff5b2d3a5c6094e94e99d2c685
|
||||
|
||||
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/p11-kit
|
||||
SECTION:=libs
|
||||
|
@ -1,22 +0,0 @@
|
||||
From 507c394cfcf4edffc5e4450c5d737e545c26b857 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Engberg <daniel.engberg.lists@pyret.net>
|
||||
Date: Sat, 12 Dec 2020 18:56:38 +0100
|
||||
Subject: [PATCH] p11-kit/lists.c: Add stdint.h to fix compilation
|
||||
|
||||
Add stdint.h otherwise compilation fails on FreeBSD 13-CURRENT with "use of undeclared identifier 'SIZE_MAX'"
|
||||
|
||||
Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
|
||||
---
|
||||
p11-kit/lists.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
--- a/p11-kit/lists.c
|
||||
+++ b/p11-kit/lists.c
|
||||
@@ -39,6 +39,7 @@
|
||||
|
||||
#include <assert.h>
|
||||
#include <ctype.h>
|
||||
+#include <stdint.h>
|
||||
#include <string.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
@ -19,13 +19,10 @@ PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/pixman
|
||||
SECTION:=libs
|
||||
|
@ -18,11 +18,9 @@ PKG_LICENSE_FILES:=COPYING
|
||||
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/spice-protocol
|
||||
SECTION:=libs
|
||||
|
@ -6,12 +6,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=grilo
|
||||
PKG_VERSION:=0.3.13
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=0.3.14
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNOME/grilo/0.3/
|
||||
PKG_HASH:=d14837f22341943ed8a189d9f0827a17016b802d18d0ed080e1413de0fdc927b
|
||||
PKG_HASH:=0369d0b00bb0f59ba5f7aea8cfc665f38df14a5b4182d28c7c1e2cd15b518743
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later
|
||||
@ -22,7 +22,7 @@ PKG_BUILD_DEPENDS:=vala/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/grilo
|
||||
SECTION:=multimedia
|
||||
|
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gst1-libav
|
||||
PKG_VERSION:=1.18.4
|
||||
PKG_VERSION:=1.18.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=gst-libav-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gst-libav
|
||||
PKG_HASH:=344a463badca216c2cef6ee36f9510c190862bdee48dc4591c0a430df7e8c396
|
||||
PKG_HASH:=822e008a910e9dd13aedbdd8dc63fedef4040c0ee2e927bab3112e9de693a548
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-libav-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||
@ -108,7 +108,7 @@ PKG_CONFIG_DEPENDS:= \
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/gst1-libav
|
||||
SECTION:=multimedia
|
||||
|
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gst1-plugins-bad
|
||||
PKG_VERSION:=1.18.4
|
||||
PKG_VERSION:=1.18.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=gst-plugins-bad-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-bad/
|
||||
PKG_HASH:=74e806bc5595b18c70e9ca93571e27e79dfb808e5d2e7967afa952b52e99c85f
|
||||
PKG_HASH:=a164923b94f0d08578a6fcaeaac6e0c05da788a46903a1086870e9ca45ad678e
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-bad-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||
@ -25,7 +25,7 @@ PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
GST_BAD_LIBS:=
|
||||
GST_BAD_MODULES:=
|
||||
|
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gst1-plugins-base
|
||||
PKG_VERSION:=1.18.4
|
||||
PKG_VERSION:=1.18.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=gst-plugins-base-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gst-plugins-base
|
||||
PKG_HASH:=29e53229a84d01d722f6f6db13087231cdf6113dd85c25746b9b58c3d68e8323
|
||||
PKG_HASH:=960b7af4585700db0fdd5b843554e11e2564fed9e061f591fae88a7be6446fa3
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-base-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||
@ -26,7 +26,7 @@ PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
PKG_CONFIG_DEPENDS:= \
|
||||
CONFIG_PACKAGE_gst1-mod-alsa \
|
||||
|
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gst1-plugins-good
|
||||
PKG_VERSION:=1.18.4
|
||||
PKG_VERSION:=1.18.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=gst-plugins-good-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gst-plugins-good/
|
||||
PKG_HASH:=b6e50e3a9bbcd56ee6ec71c33aa8332cc9c926b0c1fae995aac8b3040ebe39b0
|
||||
PKG_HASH:=3aaeeea7765fbf8801acce4a503a9b05f73f04e8a35352e9d00232cfd555796b
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-good-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||
@ -26,7 +26,7 @@ PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
PKG_CONFIG_DEPENDS:= \
|
||||
CONFIG_PACKAGE_gst1-mod-lame \
|
||||
|
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gst1-plugins-ugly
|
||||
PKG_VERSION:=1.18.4
|
||||
PKG_VERSION:=1.18.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=gst-plugins-ugly-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gst-plugins-ugly
|
||||
PKG_HASH:=218df0ce0d31e8ca9cdeb01a3b0c573172cc9c21bb3d41811c7820145623d13c
|
||||
PKG_HASH:=df32803e98f8a9979373fa2ca7e05e62f977b1097576d3a80619d9f5c69f66d9
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-ugly-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||
@ -25,7 +25,7 @@ PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
PKG_CONFIG_DEPENDS:= \
|
||||
CONFIG_PACKAGE_gst1-mod-asf \
|
||||
|
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gstreamer1
|
||||
PKG_VERSION:=1.18.4
|
||||
PKG_VERSION:=1.18.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gstreamer
|
||||
PKG_HASH:=9aeec99b38e310817012aa2d1d76573b787af47f8a725a65b833880a094dfbc5
|
||||
PKG_HASH:=55862232a63459bbf56abebde3085ca9aec211b478e891dacea4d6df8cafe80a
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||
@ -23,11 +23,11 @@ PKG_LICENSE_FILES:=COPYING
|
||||
PKG_CPE_ID:=cpe:/a:gstreamer_project:gstreamer
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=meson/host glib2/host gettext-full/host
|
||||
PKG_BUILD_DEPENDS:=glib2/host gettext-full/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/gstreamer1/Default
|
||||
CATEGORY:=Multimedia
|
||||
|
@ -23,10 +23,9 @@ PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_CPE_ID:=cpe:/a:iputils_project:iputils
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
MESON_ARGS += \
|
||||
-DBUILD_MANS=false \
|
||||
|
@ -6,22 +6,21 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mpc
|
||||
PKG_VERSION:=0.33
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=0.34
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.musicpd.org/download/mpc/0
|
||||
PKG_HASH:=4f40ccbe18f5095437283cfc525a97815e983cbfd3a29e48ff610fa4f1bf1296
|
||||
PKG_HASH:=691e3f3654bc10d022bb0310234d0bc2d8c075a698f09924d9ebed8f506fda20
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
MESON_ARGS+=-Diconv=disabled -Ddocumentation=disabled
|
||||
|
||||
|
@ -22,11 +22,10 @@ PKG_CPE_ID:=cpe:/a:pulseaudio:pulseaudio
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_USE_MIPS16:=0
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/pulseaudio/Default
|
||||
SECTION:=sound
|
||||
|
Loading…
Reference in New Issue
Block a user