mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 15:59:31 +08:00
amule: bump to 2.3.3
This commit is contained in:
parent
5adca2349a
commit
3513c27ff9
@ -8,7 +8,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=aMule
|
||||
PKG_VERSION:=2.3.2
|
||||
PKG_VERSION:=2.3.3
|
||||
PKG_RELEASE:=3
|
||||
PKG_REV=4b87b20
|
||||
|
||||
@ -18,7 +18,7 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
PKG_SOURCE_URL:=https://github.com/amule-project/amule.git
|
||||
PKG_MIRROR_HASH:=1575d31d68f9df881100c9e30f18fc7dec8493a8ae20787f41b6ef23604a78ff
|
||||
PKG_MIRROR_HASH:=102c4cb3dd2858db06fff19c5e2d0b65c6731b366f45df2adcd40fd0cd0fec47
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_BUILD_DEPENDS:=libgd libcryptopp
|
||||
|
@ -0,0 +1,25 @@
|
||||
From 46ecaeadff4c07b8fd98cf41e27605895328ce0a Mon Sep 17 00:00:00 2001
|
||||
From: W_Y_CPP <383152993@qq.com>
|
||||
Date: Thu, 2 Dec 2021 00:46:12 -0800
|
||||
Subject: [PATCH] fix API mismatch with crypto++ 6.0.0
|
||||
|
||||
---
|
||||
src/ClientCreditsList.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/ClientCreditsList.cpp b/src/ClientCreditsList.cpp
|
||||
index d61e8d4..b02e162 100644
|
||||
--- a/src/ClientCreditsList.cpp
|
||||
+++ b/src/ClientCreditsList.cpp
|
||||
@@ -312,7 +312,7 @@ void CClientCreditsList::InitalizeCrypting()
|
||||
// calculate and store public key
|
||||
CryptoPP::RSASSA_PKCS1v15_SHA_Verifier pubkey(*static_cast<CryptoPP::RSASSA_PKCS1v15_SHA_Signer *>(m_pSignkey));
|
||||
CryptoPP::ArraySink asink(m_abyMyPublicKey, 80);
|
||||
- pubkey.DEREncode(asink);
|
||||
+ pubkey.GetMaterial().Save(asink);
|
||||
m_nMyPublicKeyLen = asink.TotalPutLength();
|
||||
asink.MessageEnd();
|
||||
} catch (const CryptoPP::Exception& e) {
|
||||
--
|
||||
2.17.1
|
||||
|
2285
net/amule/patches/0002-fix-byte-type-error.patch
Normal file
2285
net/amule/patches/0002-fix-byte-type-error.patch
Normal file
File diff suppressed because it is too large
Load Diff
25
net/amule/patches/0003-fix-set_terminate.patch
Normal file
25
net/amule/patches/0003-fix-set_terminate.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From dcc605e06e106b05bc5e756eeeeb17abbc1a6e5c Mon Sep 17 00:00:00 2001
|
||||
From: W_Y_CPP <383152993@qq.com>
|
||||
Date: Wed, 1 Dec 2021 23:13:08 -0800
|
||||
Subject: [PATCH] fix set_terminate
|
||||
|
||||
---
|
||||
src/libs/common/MuleDebug.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/libs/common/MuleDebug.cpp b/src/libs/common/MuleDebug.cpp
|
||||
index 5d8d758..14206f9 100644
|
||||
--- a/src/libs/common/MuleDebug.cpp
|
||||
+++ b/src/libs/common/MuleDebug.cpp
|
||||
@@ -24,7 +24,7 @@
|
||||
//
|
||||
|
||||
#include <cstdlib> // Needed for std::abort()
|
||||
-
|
||||
+#include <exception>
|
||||
#ifdef HAVE_CONFIG_H
|
||||
# include "config.h" // Needed for HAVE_CXXABI and HAVE_EXECINFO
|
||||
#endif
|
||||
--
|
||||
2.17.1
|
||||
|
Loading…
Reference in New Issue
Block a user