mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 08:09:23 +08:00
samba4: update to 4.14.14 (#556)
* samba4: add riscv64 support Required for sifiveu target. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> * samba4: update waf-cross-answers * update waf-cross-answers for 4.14.x Signed-off-by: Andrew Sim <andrewsimz@gmail.com> * samba4: fix build on macos This commit fixes two issues on macos: 1. Added a patch to fix 'echo -n' issue with MacOS shell (backported from upstream) 2. Redefined sys.platform='linux' for target build if build host is MacOS (otherwise, build script tries to use MacOS logic for OpenWrt(Linux) target build) Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in> * samba4: update to 4.14.14 * update to 4.14.14 * fixes: CVE-2022-2031, CVE-2022-32744, CVE-2022-32745, CVE-2022-32746, CVE-2022-32742 Signed-off-by: Andrew Sim <andrewsimz@gmail.com> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> Signed-off-by: Andrew Sim <andrewsimz@gmail.com> Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in> Co-authored-by: Zoltan HERPAI <wigyori@uid0.hu> Co-authored-by: Andrew Sim <andrewsimz@gmail.com> Co-authored-by: Sergey V. Lobanov <sergey@lobanov.in>
This commit is contained in:
parent
35bd7e01da
commit
1e71e76be8
@ -2,7 +2,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=samba
|
||||
PKG_VERSION:=4.14.12
|
||||
PKG_VERSION:=4.14.14
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
@ -13,7 +13,7 @@ PKG_SOURCE_URL:= \
|
||||
http://www.nic.funet.fi/index/samba/pub/samba/stable/ \
|
||||
http://samba.mirror.bit.nl/samba/ftp/stable/ \
|
||||
https://download.samba.org/pub/samba/stable/
|
||||
PKG_HASH:=155d9c2dfb06a18104422987590858bfe5e9783ebebe63882e7e7f07eaaa512d
|
||||
PKG_HASH:=abd5e9e6aa45e55114b188ba189ebdfc8fd3d7718d43f749e477ce7f791e5519
|
||||
|
||||
PKG_LICENSE:=GPL-3.0-only
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
@ -350,6 +350,9 @@ ifeq ($(CONFIG_SAMBA4_SERVER_AD_DC),)
|
||||
# unbundle iso8601
|
||||
$(SED) '/"iso8601":/d' $(PKG_BUILD_DIR)/third_party/wscript
|
||||
endif
|
||||
ifeq ($(CONFIG_HOST_OS_MACOS),y)
|
||||
$(SED) "/^VERSION=/i sys.platform='linux'" $(PKG_BUILD_DIR)/buildtools/bin/waf
|
||||
endif
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
|
@ -0,0 +1,30 @@
|
||||
From: https://gitlab.com/samba-team/samba/-/commit/29f11005f56ebc2202e7883ea4d9ca7e7a46d9bb
|
||||
|
||||
From 29f11005f56ebc2202e7883ea4d9ca7e7a46d9bb Mon Sep 17 00:00:00 2001
|
||||
From: "Sergey V. Lobanov" <sergey@lobanov.in>
|
||||
Date: Thu, 10 Feb 2022 00:02:17 +0300
|
||||
Subject: [PATCH] wafsamba: replace 'echo -n' with printf
|
||||
|
||||
This patch makes samba_cross.py compatible with old bash (e.g. 3.2)
|
||||
|
||||
Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
|
||||
Reviewed-by: Christof Schmitt <cs@samba.org>
|
||||
Reviewed-by: Andreas Schneider <asn@samba.org>
|
||||
|
||||
Autobuild-User(master): Andreas Schneider <asn@cryptomilk.org>
|
||||
Autobuild-Date(master): Fri Feb 11 07:58:57 UTC 2022 on sn-devel-184
|
||||
---
|
||||
buildtools/wafsamba/samba_cross.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/buildtools/wafsamba/samba_cross.py
|
||||
+++ b/buildtools/wafsamba/samba_cross.py
|
||||
@@ -134,7 +134,7 @@ class cross_Popen(Utils.subprocess.Popen
|
||||
cross_answers_incomplete = True
|
||||
add_answer(ca_file, msg, ans)
|
||||
(retcode, retstring) = ans
|
||||
- args = ['/bin/sh', '-c', "echo -n '%s'; exit %d" % (retstring, retcode)]
|
||||
+ args = ['/bin/sh', '-c', "printf %%s '%s'; exit %d" % (retstring, retcode)]
|
||||
real_Popen.__init__(*(obj, args), **kw)
|
||||
|
||||
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: OK
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
@ -39,3 +39,4 @@ getcwd takes a NULL argument: OK
|
||||
Checking whether setreuid is available: NO
|
||||
Checking whether setresuid is available: NO
|
||||
Checking whether seteuid is available: NO
|
||||
Checking for readlink breakage: OK
|
||||
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: NO
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: NO
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: NO
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: NO
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: OK
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: OK
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: NO
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: NO
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: OK
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
39
net/samba4/waf-cross-answers/riscv64.txt
Normal file
39
net/samba4/waf-cross-answers/riscv64.txt
Normal file
@ -0,0 +1,39 @@
|
||||
Checking uname sysname type: "Linux"
|
||||
Checking simple C program: "hello world"
|
||||
rpath library support: OK
|
||||
-Wl,--version-script support: OK
|
||||
Checking getconf LFS_CFLAGS: NO
|
||||
Checking for large file support without additional flags: OK
|
||||
Checking correct behavior of strtoll: OK
|
||||
Checking for working strptime: NO
|
||||
Checking for C99 vsnprintf: "1"
|
||||
Checking for HAVE_SHARED_MMAP: OK
|
||||
Checking for HAVE_MREMAP: OK
|
||||
Checking for HAVE_INCOHERENT_MMAP: NO
|
||||
Checking for HAVE_SECURE_MKSTEMP: OK
|
||||
Checking for HAVE_IFACE_GETIFADDRS: OK
|
||||
Checking value of NSIG: "65"
|
||||
Checking value of _NSIG: "65"
|
||||
Checking value of SIGRTMAX: "64"
|
||||
Checking value of SIGRTMIN: "35"
|
||||
Checking for a 64-bit host to support lmdb: OK
|
||||
Checking value of GNUTLS_CIPHER_AES_128_CFB8: "29"
|
||||
Checking value of GNUTLS_MAC_AES_CMAC_128: "203"
|
||||
Checking errno of iconv for illegal multibyte sequence: OK
|
||||
Checking for kernel change notify support: OK
|
||||
Checking for Linux kernel oplocks: OK
|
||||
Checking for kernel share modes: OK
|
||||
Checking whether POSIX capabilities are available: OK
|
||||
Checking if can we convert from CP850 to UCS-2LE: OK
|
||||
Checking if can we convert from UTF-8 to UCS-2LE: OK
|
||||
vfs_fileid checking for statfs() and struct statfs.f_fsid: OK
|
||||
Checking whether we can use Linux thread-specific credentials: OK
|
||||
Checking whether fcntl locking is available: OK
|
||||
Checking whether fcntl lock supports open file description locks: NO
|
||||
Checking whether fcntl supports flags to send direct I/O availability signals: OK
|
||||
Checking whether fcntl supports setting/geting hints: (-11, "")
|
||||
Checking for the maximum value of the 'time_t' type: OK
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
@ -36,3 +36,4 @@ Checking for the maximum value of the 'time_t' type: OK
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking for ftruncate extend: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking for readlink breakage: OK
|
||||
|
Loading…
Reference in New Issue
Block a user