mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 15:22:43 +08:00
libev: bump version
This commit is contained in:
parent
080e3d6381
commit
1751e355e0
@ -8,22 +8,20 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=freetype
|
PKG_NAME:=freetype
|
||||||
PKG_VERSION:=2.10.4
|
PKG_VERSION:=2.11.0
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@SF/freetype
|
PKG_SOURCE_URL:=@SF/freetype
|
||||||
PKG_HASH:=86a854d8905b19698bbc8f23b860bc104246ce4854dcea8e3b0fb21284f75784
|
PKG_HASH:=8bee39bd3968c4804b70614a0a3ad597299ad0e824bc8aad5ce8aaf48067bde7
|
||||||
|
|
||||||
PKG_MAINTAINER:=Val Kulkov <val.kulkov@gmail.com>
|
PKG_MAINTAINER:=Val Kulkov <val.kulkov@gmail.com>
|
||||||
PKG_LICENSE:=FTL GPL-2.0-only MIT ZLIB GPL-3.0-or-later
|
PKG_LICENSE:=FTL GPL-2.0-only MIT ZLIB GPL-3.0-or-later
|
||||||
PKG_LICENSE_FILES:=docs/LICENSE.TXT docs/FTL.TXT docs/GPLv2.TXT src/bdf/README src/pcf/README src/gzip/zlib.h builds/unix/config.sub builds/unix/config.guess builds/unix/libtool
|
PKG_LICENSE_FILES:=docs/LICENSE.TXT docs/FTL.TXT docs/GPLv2.TXT src/bdf/README src/pcf/README src/gzip/zlib.h builds/unix/config.sub builds/unix/config.guess builds/unix/libtool
|
||||||
PKG_CPE_ID:=cpe:/a:freetype:freetype2
|
PKG_CPE_ID:=cpe:/a:freetype:freetype2
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=meson/host
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include ../../devel/meson/meson.mk
|
include $(INCLUDE_DIR)/meson.mk
|
||||||
|
|
||||||
define Package/libfreetype
|
define Package/libfreetype
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
@ -41,7 +39,7 @@ define Package/libfreetype/description
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
MESON_ARGS += \
|
MESON_ARGS += \
|
||||||
-Dzlib=system \
|
-Dzlib=enabled \
|
||||||
-Dbzip2=disabled \
|
-Dbzip2=disabled \
|
||||||
-Dpng=enabled \
|
-Dpng=enabled \
|
||||||
-Dharfbuzz=disabled \
|
-Dharfbuzz=disabled \
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
From 40c5681ab92e7db1298273ccf3c816e6a1498260 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Werner Lemberg <wl@gnu.org>
|
|
||||||
Date: Mon, 26 Oct 2020 18:09:56 +0100
|
|
||||||
Subject: [PATCH] * meson.build: Fix 'harfbuzz' and 'brotli' build options
|
|
||||||
(#59347).
|
|
||||||
|
|
||||||
Without this patch, 'harfbuzz' and 'brotli' are always required.
|
|
||||||
|
|
||||||
Patch submitted anonymously in Savannah bug report.
|
|
||||||
---
|
|
||||||
meson.build | 12 ++++++++----
|
|
||||||
1 file changed, 8 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -267,13 +267,17 @@ ft2_deps += [libpng_dep]
|
|
||||||
harfbuzz_dep = dependency('harfbuzz',
|
|
||||||
version: '>= 1.8.0',
|
|
||||||
required: get_option('harfbuzz'))
|
|
||||||
-ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_HARFBUZZ']
|
|
||||||
-ft2_deps += [harfbuzz_dep]
|
|
||||||
+if harfbuzz_dep.found()
|
|
||||||
+ ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_HARFBUZZ']
|
|
||||||
+ ft2_deps += [harfbuzz_dep]
|
|
||||||
+endif
|
|
||||||
|
|
||||||
# Brotli decompression support
|
|
||||||
brotli_dep = dependency('libbrotlidec', required: get_option('brotli'))
|
|
||||||
-ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_BROTLI']
|
|
||||||
-ft2_deps += [brotli_dep]
|
|
||||||
+if brotli_dep.found()
|
|
||||||
+ ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_BROTLI']
|
|
||||||
+ ft2_deps += [brotli_dep]
|
|
||||||
+endif
|
|
||||||
|
|
||||||
# We can now generate `ftoption.h`.
|
|
||||||
ftoption_h = custom_target('ftoption.h',
|
|
@ -1,11 +0,0 @@
|
|||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -26,7 +26,7 @@ project('freetype2', 'c',
|
|
||||||
# running an external command is required.
|
|
||||||
|
|
||||||
python = import('python')
|
|
||||||
-python_exe = python.find_installation(required: true)
|
|
||||||
+python_exe = 'python3'
|
|
||||||
|
|
||||||
ft2_version = run_command(python_exe,
|
|
||||||
files('builds/meson/extract_freetype_version.py'),
|
|
@ -1,56 +0,0 @@
|
|||||||
From 26e2a89598d69c7aba76c83f6a1fcf1db17574ab Mon Sep 17 00:00:00 2001
|
|
||||||
From: Werner Lemberg <wl@gnu.org>
|
|
||||||
Date: Wed, 4 Nov 2020 21:00:22 +0100
|
|
||||||
Subject: [PATCH] * meson.build: Fix .pc file generation.
|
|
||||||
|
|
||||||
For backwards compatibility we need the libtool version, not the .so
|
|
||||||
number.
|
|
||||||
|
|
||||||
Reported by Nikolaus.
|
|
||||||
|
|
||||||
Downloaded from upstream commit:
|
|
||||||
https://gitlab.freedesktop.org/freetype/freetype/-/commit/26e2a89598d69c7aba76c83f6a1fcf1db17574ab
|
|
||||||
|
|
||||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
||||||
---
|
|
||||||
ChangeLog | 9 +++++++++
|
|
||||||
meson.build | 10 +++++++---
|
|
||||||
2 files changed, 16 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -32,11 +32,15 @@ ft2_version = run_command(python_exe,
|
|
||||||
files('builds/meson/extract_freetype_version.py'),
|
|
||||||
files('include/freetype/freetype.h')).stdout().strip()
|
|
||||||
|
|
||||||
-ft2_libtool_version = run_command(python_exe,
|
|
||||||
+ft2_so_version = run_command(python_exe,
|
|
||||||
files('builds/meson/extract_libtool_version.py'),
|
|
||||||
'--soversion',
|
|
||||||
files('builds/unix/configure.raw')).stdout().strip()
|
|
||||||
|
|
||||||
+ft2_libtool_version = run_command(python_exe,
|
|
||||||
+ files('builds/meson/extract_libtool_version.py'),
|
|
||||||
+ files('builds/unix/configure.raw')).stdout().strip()
|
|
||||||
+
|
|
||||||
ft2_includes = include_directories('include')
|
|
||||||
|
|
||||||
|
|
||||||
@@ -320,7 +324,7 @@ ft2_lib = library('freetype',
|
|
||||||
include_directories: ft2_includes,
|
|
||||||
dependencies: ft2_deps,
|
|
||||||
install: true,
|
|
||||||
- version: ft2_libtool_version,
|
|
||||||
+ version: ft2_so_version,
|
|
||||||
)
|
|
||||||
|
|
||||||
|
|
||||||
@@ -328,7 +332,7 @@ ft2_lib = library('freetype',
|
|
||||||
freetype2_dep = declare_dependency(
|
|
||||||
include_directories: ft2_includes,
|
|
||||||
link_with: ft2_lib,
|
|
||||||
- version: ft2_libtool_version)
|
|
||||||
+ version: ft2_so_version)
|
|
||||||
|
|
||||||
|
|
||||||
# NOTE: Using both `install_dir` and `subdir` doesn't seem to work below,
|
|
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libev
|
PKG_NAME:=libev
|
||||||
PKG_VERSION:=4.31
|
PKG_VERSION:=4.33
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://dist.schmorp.de/libev/Attic/
|
PKG_SOURCE_URL:=http://dist.schmorp.de/libev/Attic/
|
||||||
PKG_HASH:=ed855d2b52118e32c0c1a6a32bd18c97f9e6711ca511f5ee12de3b9eccc66e5a
|
PKG_HASH:=507eb7b8d1015fbec5b935f34ebed15bf346bed04a11ab82b8eee848c4205aea
|
||||||
PKG_LICENSE:=BSD-2-Clause
|
PKG_LICENSE:=BSD-2-Clause
|
||||||
PKG_MAINTAINER:=Karl Palsson <karlp@tweak.net.au>
|
PKG_MAINTAINER:=Karl Palsson <karlp@tweak.net.au>
|
||||||
|
|
||||||
|
@ -5,22 +5,21 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libevdev
|
PKG_NAME:=libevdev
|
||||||
PKG_VERSION:=1.11.0
|
PKG_VERSION:=1.12.0
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://www.freedesktop.org/software/libevdev/
|
PKG_SOURCE_URL:=https://www.freedesktop.org/software/libevdev/
|
||||||
PKG_HASH:=63f4ea1489858a109080e0b40bd43e4e0903a1e12ea888d581db8c495747c2d0
|
PKG_HASH:=2f729e3480695791f9482e8388bd723402b89f0eaf118057bbdea3cecee9b237
|
||||||
|
|
||||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_DEPENDS:=meson/host
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include ../../devel/meson/meson.mk
|
include $(INCLUDE_DIR)/meson.mk
|
||||||
|
|
||||||
define Package/libevdev
|
define Package/libevdev
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
|
@ -6,23 +6,22 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=grilo-plugins
|
PKG_NAME:=grilo-plugins
|
||||||
PKG_VERSION:=0.3.13
|
PKG_VERSION:=0.3.14
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
|
||||||
PKG_LICENSE:=LGPLv2.1
|
|
||||||
PKG_LICENSE_FILES:=COPYING
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNOME/grilo-plugins/0.3/
|
PKG_SOURCE_URL:=@GNOME/grilo-plugins/0.3/
|
||||||
PKG_HASH:=1c4305d67364a930543836cc1982f30e946973b8ff6af3efe31d87709ab520f8
|
PKG_HASH:=686844b34ec73b24931ff6cc4f6033f0072947a6db60acdc7fb3eaf157a581c8
|
||||||
|
|
||||||
|
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||||
|
PKG_LICENSE:=LGPL-2.1-or-later
|
||||||
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_DEPENDS:=meson/host
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/nls.mk
|
include $(INCLUDE_DIR)/nls.mk
|
||||||
include ../../devel/meson/meson.mk
|
include $(INCLUDE_DIR)/meson.mk
|
||||||
|
|
||||||
define Package/grilo-plugins/Default
|
define Package/grilo-plugins/Default
|
||||||
SECTION:=multimedia
|
SECTION:=multimedia
|
||||||
@ -52,13 +51,13 @@ MESON_ARGS += \
|
|||||||
-Denable-filesystem=no \
|
-Denable-filesystem=no \
|
||||||
-Denable-flickr=no \
|
-Denable-flickr=no \
|
||||||
-Denable-freebox=no \
|
-Denable-freebox=no \
|
||||||
-Denable_gravatar=$(if $(CONFIG_PACKAGE_grilo-plugins-gravatar),yes,no) \
|
-Denable-gravatar=$(if $(CONFIG_PACKAGE_grilo-plugins-gravatar),yes,no) \
|
||||||
-Dhelp=no \
|
-Dhelp=no \
|
||||||
-Denable-local-metadata=no \
|
-Denable-local-metadata=no \
|
||||||
-Denable-lua-factory=no \
|
-Denable-lua-factory=no \
|
||||||
-Denable-magnatune=$(if $(CONFIG_PACKAGE_grilo-plugins-magnatune),yes,no) \
|
-Denable-magnatune=$(if $(CONFIG_PACKAGE_grilo-plugins-magnatune),yes,no) \
|
||||||
-Denable-metadata-store=$(if $(CONFIG_PACKAGE_grilo-plugins-metadata-store),yes,no) \
|
-Denable-metadata-store=$(if $(CONFIG_PACKAGE_grilo-plugins-metadata-store),yes,no) \
|
||||||
-Denable_opensubtitles=$(if $(CONFIG_PACKAGE_grilo-plugins-opensubtitles),yes,no) \
|
-Denable-opensubtitles=$(if $(CONFIG_PACKAGE_grilo-plugins-opensubtitles),yes,no) \
|
||||||
-Denable-optical-media=no \
|
-Denable-optical-media=no \
|
||||||
-Denable-podcasts=no \
|
-Denable-podcasts=no \
|
||||||
-Denable-raitv=$(if $(CONFIG_PACKAGE_grilo-plugins-raitv),yes,no) \
|
-Denable-raitv=$(if $(CONFIG_PACKAGE_grilo-plugins-raitv),yes,no) \
|
||||||
@ -67,7 +66,6 @@ MESON_ARGS += \
|
|||||||
-Denable-tmdb=$(if $(CONFIG_PACKAGE_grilo-plugins-tmdb),yes,no) \
|
-Denable-tmdb=$(if $(CONFIG_PACKAGE_grilo-plugins-tmdb),yes,no) \
|
||||||
-Denable-tracker=no \
|
-Denable-tracker=no \
|
||||||
-Denable-tracker3=no \
|
-Denable-tracker3=no \
|
||||||
-Denable-vimeo=no \
|
|
||||||
-Denable-youtube=no \
|
-Denable-youtube=no \
|
||||||
--wrap-mode=nodownload
|
--wrap-mode=nodownload
|
||||||
|
|
||||||
|
@ -21,10 +21,9 @@ PKG_LICENSE:=GPL-2.0-or-later
|
|||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_DEPENDS:=meson/host
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include ../../devel/meson/meson.mk
|
include $(INCLUDE_DIR)/meson.mk
|
||||||
include flashrom.mk
|
include flashrom.mk
|
||||||
|
|
||||||
define Package/flashrom/default
|
define Package/flashrom/default
|
||||||
|
@ -9,22 +9,21 @@ include $(TOPDIR)/rules.mk
|
|||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=fuse3
|
PKG_NAME:=fuse3
|
||||||
PKG_VERSION:=3.10.1
|
PKG_VERSION:=3.10.5
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=fuse-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=fuse-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://github.com/libfuse/libfuse/releases/download/fuse-$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/libfuse/libfuse/releases/download/fuse-$(PKG_VERSION)
|
||||||
PKG_HASH:=d82d74d4c03e099f806e4bb31483955637c69226576bf0ca9bd142f1d50ae451
|
PKG_HASH:=b2e283485d47404ac896dd0bb7f7ba81e1470838e677e45f659804c3a3b69666
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/fuse-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/fuse-$(PKG_VERSION)
|
||||||
|
|
||||||
PKG_MAINTAINER:=
|
PKG_MAINTAINER:=
|
||||||
PKG_CPE_ID:=cpe:/a:fuse_project:fuse
|
PKG_CPE_ID:=cpe:/a:fuse_project:fuse
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_DEPENDS:=meson/host
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include ../../devel/meson/meson.mk
|
include $(INCLUDE_DIR)/meson.mk
|
||||||
|
|
||||||
define Package/fuse3/Default
|
define Package/fuse3/Default
|
||||||
TITLE:=FUSE
|
TITLE:=FUSE
|
||||||
|
Loading…
Reference in New Issue
Block a user