mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 01:03:34 +08:00
glib2: fix mips16 build, add size reducing static link, fpic CFLAGS
This commit is contained in:
parent
feff5fca72
commit
15de7297b9
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=glib2
|
||||
PKG_VERSION:=2.58.3
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
|
||||
@ -21,7 +21,6 @@ HOST_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_DEPENDS:=gettext
|
||||
HOST_BUILD_DEPENDS:=gettext-full/host libiconv/host libffi/host
|
||||
PKG_INSTALL:=1
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
PKG_CPE_ID:=cpe:/a:gnome:glib
|
||||
|
||||
@ -46,7 +45,7 @@ define Package/glib2/description
|
||||
The GLib library of C routines
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -Wno-error=implicit-function-declaration
|
||||
TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections -flto
|
||||
|
||||
HOST_CONFIGURE_ARGS += \
|
||||
--disable-libelf \
|
||||
@ -64,6 +63,7 @@ CONFIGURE_ARGS += \
|
||||
--disable-fam \
|
||||
--disable-gtk-doc-html \
|
||||
--disable-man \
|
||||
--disable-compile-warnings \
|
||||
--with-libiconv=gnu \
|
||||
--with-pcre=internal
|
||||
|
||||
|
11
libs/glib2/patches/003-valgrind.h-mips16-fix.patch
Normal file
11
libs/glib2/patches/003-valgrind.h-mips16-fix.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/glib/valgrind.h 2019-12-12 14:53:26.000200499 +0100
|
||||
+++ b/glib/valgrind.h 2019-12-12 14:49:45.056163300 +0100
|
||||
@@ -157,7 +157,7 @@
|
||||
# define PLAT_s390x_linux 1
|
||||
#elif defined(__linux__) && defined(__mips__) && (__mips==64)
|
||||
# define PLAT_mips64_linux 1
|
||||
-#elif defined(__linux__) && defined(__mips__) && (__mips!=64)
|
||||
+#elif defined(__linux__) && defined(__mips__) && (__mips!=64) && !defined(__mips16)
|
||||
# define PLAT_mips32_linux 1
|
||||
#elif defined(__sun) && defined(__i386__)
|
||||
# define PLAT_x86_solaris 1
|
Loading…
Reference in New Issue
Block a user