mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-01 11:51:33 +08:00
xl2tpd: bump version
This commit is contained in:
parent
d9ba47517e
commit
10e86977aa
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=netdata
|
PKG_NAME:=netdata
|
||||||
PKG_VERSION:=1.18.0
|
PKG_VERSION:=1.18.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>, Daniel Engberg <daniel.engberg.lists@pyret.net>
|
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>, Daniel Engberg <daniel.engberg.lists@pyret.net>
|
||||||
PKG_LICENSE:=GPL-3.0-or-later
|
PKG_LICENSE:=GPL-3.0-or-later
|
||||||
|
@ -25,5 +25,8 @@
|
|||||||
node.d = no
|
node.d = no
|
||||||
python.d = no
|
python.d = no
|
||||||
|
|
||||||
|
[plugin:proc:ipc]
|
||||||
|
semaphore totals = no
|
||||||
|
|
||||||
[health]
|
[health]
|
||||||
enabled = no
|
enabled = no
|
||||||
|
@ -8,8 +8,8 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=xl2tpd
|
PKG_NAME:=xl2tpd
|
||||||
PKG_VERSION:=1.3.12
|
PKG_VERSION:=1.3.15
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=3
|
||||||
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
|
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
|
||||||
PKG_LICENSE:=GPL-2.0
|
PKG_LICENSE:=GPL-2.0
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
@ -19,9 +19,7 @@ PKG_SOURCE_URL:=https://github.com/xelerance/xl2tpd.git
|
|||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_MIRROR_HASH:=271d40aaf97a07e4c1bbcfb9c0081f2fc848fa7ef6d69c43c141a4e5a749831d
|
PKG_MIRROR_HASH:=e12232fef216a1cb5b74f990616aff1dd851c62812ef54658a330629823c0996
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=libpcap
|
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
@ -34,7 +34,7 @@ netifd will not do the check and retry.
|
|||||||
|
|
||||||
The following are generic ppp options and should have the same format and
|
The following are generic ppp options and should have the same format and
|
||||||
semantics as with other ppp-related protocols. See
|
semantics as with other ppp-related protocols. See
|
||||||
[uci/network#protocol_ppp](https://wiki.openwrt.org/doc/uci/network#protocol_ppp_ppp_over_modem)
|
[uci/network#protocol_ppp](https://openwrt.org/docs/guide-user/network/wan/wan_interface_protocols#protocol_ppp_ppp_over_modem)
|
||||||
for details.
|
for details.
|
||||||
|
|
||||||
username
|
username
|
||||||
|
61
net/xl2tpd/patches/0001-Skip-building-pfc.patch
Normal file
61
net/xl2tpd/patches/0001-Skip-building-pfc.patch
Normal file
@ -0,0 +1,61 @@
|
|||||||
|
From 1d11b2432b6e0f99b9f08c65b51292e1a2251975 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Yousong Zhou <zhouyousong@yunionyun.com>
|
||||||
|
Date: Fri, 18 Oct 2019 11:29:03 +0000
|
||||||
|
Subject: [PATCH] Skip building pfc
|
||||||
|
|
||||||
|
It can cause build failure, see [1]
|
||||||
|
|
||||||
|
[1] https://github.com/openwrt/packages/issues/10270
|
||||||
|
---
|
||||||
|
Makefile | 15 +++------------
|
||||||
|
1 file changed, 3 insertions(+), 12 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 9927715..8a3eecd 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -115,10 +115,10 @@ BINDIR?=$(DESTDIR)${PREFIX}/bin
|
||||||
|
MANDIR?=$(DESTDIR)${PREFIX}/share/man
|
||||||
|
|
||||||
|
|
||||||
|
-all: $(EXEC) pfc $(CONTROL_EXEC)
|
||||||
|
+all: $(EXEC) $(CONTROL_EXEC)
|
||||||
|
|
||||||
|
clean:
|
||||||
|
- rm -f $(OBJS) $(EXEC) pfc.o pfc $(CONTROL_EXEC)
|
||||||
|
+ rm -f $(OBJS) $(EXEC) $(CONTROL_EXEC)
|
||||||
|
|
||||||
|
$(EXEC): $(OBJS) $(HDRS)
|
||||||
|
$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LDLIBS)
|
||||||
|
@@ -126,10 +126,6 @@ $(EXEC): $(OBJS) $(HDRS)
|
||||||
|
$(CONTROL_EXEC): $(CONTROL_SRCS)
|
||||||
|
$(CC) $(CFLAGS) $(LDFLAGS) $(CONTROL_SRCS) -o $@
|
||||||
|
|
||||||
|
-pfc:
|
||||||
|
- $(CC) $(CFLAGS) -c contrib/pfc.c
|
||||||
|
- $(CC) $(LDFLAGS) -o pfc pfc.o -lpcap $(LDLIBS)
|
||||||
|
-
|
||||||
|
romfs:
|
||||||
|
$(ROMFSINST) /bin/$(EXEC)
|
||||||
|
|
||||||
|
@@ -142,7 +138,7 @@ packagingprep:
|
||||||
|
sed -i "s/Version: .*/Version: ${XL2TPDBASEVERSION}/" packaging/*/*.spec
|
||||||
|
sed -i "s/PKG_VERSION:=.*/PKG_VERSION:=${XL2TPDBASEVERSION}/" packaging/openwrt/Makefile
|
||||||
|
|
||||||
|
-install: ${EXEC} pfc ${CONTROL_EXEC}
|
||||||
|
+install: ${EXEC} ${CONTROL_EXEC}
|
||||||
|
install -d -m 0755 ${SBINDIR}
|
||||||
|
install -m 0755 $(EXEC) ${SBINDIR}/$(EXEC)
|
||||||
|
install -d -m 0755 ${MANDIR}/man5
|
||||||
|
@@ -151,11 +147,6 @@ install: ${EXEC} pfc ${CONTROL_EXEC}
|
||||||
|
install -m 0644 doc/xl2tpd-control.8 ${MANDIR}/man8/
|
||||||
|
install -m 0644 doc/xl2tpd.conf.5 doc/l2tp-secrets.5 \
|
||||||
|
${MANDIR}/man5/
|
||||||
|
- # pfc
|
||||||
|
- install -d -m 0755 ${BINDIR}
|
||||||
|
- install -m 0755 pfc ${BINDIR}/pfc
|
||||||
|
- install -d -m 0755 ${MANDIR}/man1
|
||||||
|
- install -m 0644 contrib/pfc.1 ${MANDIR}/man1/
|
||||||
|
# control exec
|
||||||
|
install -d -m 0755 ${SBINDIR}
|
||||||
|
install -m 0755 $(CONTROL_EXEC) ${SBINDIR}/$(CONTROL_EXEC)
|
Loading…
Reference in New Issue
Block a user