mirror of
https://github.com/coolsnowwolf/packages.git
synced 2025-05-02 10:20:50 +08:00
glib2: fix meson
This commit is contained in:
parent
f26019aa64
commit
0ac1de14f8
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=glib2
|
||||
PKG_VERSION:=2.68.4
|
||||
PKG_VERSION:=2.70.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNOME/glib/2.68
|
||||
PKG_HASH:=62fd061d08a75492617e625a73e2c05e259f831acbb8e1f8b9c81f23f7993a3b
|
||||
PKG_SOURCE_URL:=@GNOME/glib/2.70
|
||||
PKG_HASH:=200d7df811c5ba634afbf109f14bb40ba7fde670e89389885da14e27c0840742
|
||||
|
||||
PKG_MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later
|
||||
@ -22,20 +22,20 @@ PKG_CPE_ID:=cpe:/a:gnome:glib
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
|
||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/glib-$(PKG_VERSION)
|
||||
PKG_BUILD_DEPENDS:=meson/host gettext-full libiconv/host
|
||||
HOST_BUILD_DEPENDS:=meson/host gettext-full/host libiconv/host libffi/host
|
||||
PKG_BUILD_DEPENDS:=libiconv/host
|
||||
HOST_BUILD_DEPENDS:=libiconv/host libffi/host pcre/host
|
||||
PKG_CONFIG_DEPENDS:=CONFIG_BUILD_NLS
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/glib2
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +zlib +libpthread +libffi +libattr
|
||||
DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +zlib +libpthread +libffi +libattr +libpcre
|
||||
TITLE:=glib 2.0
|
||||
URL:=http://www.gtk.org/
|
||||
endef
|
||||
@ -44,16 +44,14 @@ define Package/glib2/description
|
||||
The GLib library of C routines
|
||||
endef
|
||||
|
||||
HOST_LDFLAGS += -liconv -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib
|
||||
HOST_LDFLAGS += -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib
|
||||
TARGET_CFLAGS += -ffunction-sections -fdata-sections
|
||||
TARGET_LDFLAGS += -Wl,--gc-sections $(if $(INTL_FULL),-lintl)
|
||||
|
||||
COMP_ARGS= \
|
||||
-Ddefault_library=both \
|
||||
-Diconv=external \
|
||||
-Dselinux=disabled \
|
||||
-Dlibmount=disabled \
|
||||
-Dinternal_pcre=true \
|
||||
-Dman=false \
|
||||
-Ddtrace=false \
|
||||
-Dsystemtap=false \
|
||||
@ -64,15 +62,14 @@ COMP_ARGS= \
|
||||
-Dfam=false \
|
||||
-Dtests=false \
|
||||
-Dinstalled_tests=false \
|
||||
-Dnls=$(if $(CONFIG_BUILD_NLS),en,dis)abled \
|
||||
-Doss_fuzz=disabled \
|
||||
-Dglib_debug=disabled \
|
||||
-Dglib_assert=false \
|
||||
-Dglib_checks=false \
|
||||
-Dlibelf=disabled
|
||||
|
||||
MESON_HOST_ARGS += $(COMP_ARGS) -Dxattr=false
|
||||
MESON_ARGS += $(COMP_ARGS) -Dxattr=true -Db_lto=true
|
||||
MESON_HOST_ARGS += $(COMP_ARGS) -Dxattr=false -Ddefault_library=static -Dnls=disabled
|
||||
MESON_ARGS += $(COMP_ARGS) -Dxattr=true -Db_lto=true -Ddefault_library=both -Dnls=$(if $(CONFIG_BUILD_NLS),en,dis)abled
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -2220,16 +2220,10 @@ endif
|
||||
|
||||
glib_conf.set('HAVE_PROC_SELF_CMDLINE', have_proc_self_cmdline)
|
||||
|
||||
-python = import('python').find_installation('python3')
|
||||
+python = 'python3'
|
||||
# used for '#!/usr/bin/env <name>'
|
||||
python_name = 'python3'
|
||||
|
||||
-python_version = python.language_version()
|
||||
-python_version_req = '>=3.5'
|
||||
-if not python_version.version_compare(python_version_req)
|
||||
- error('Requires Python @0@, @1@ found.'.format(python_version_req, python_version))
|
||||
-endif
|
||||
-
|
||||
# Determine which user environment-dependent files that we want to install
|
||||
have_bash = find_program('bash', required : false).found() # For completion scripts
|
||||
bash_comp_dep = dependency('bash-completion', version: '>=2.0', required: false)
|
@ -1,13 +0,0 @@
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -2038,8 +2038,8 @@ endif
|
||||
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
|
||||
# implementations. This could be extended if issues are found in some platforms.
|
||||
libintl_deps = []
|
||||
-if cc.has_function('ngettext')
|
||||
- have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
|
||||
+if true
|
||||
+ have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset', prefix :'#include <libintl.h>')
|
||||
else
|
||||
# First just find the bare library.
|
||||
libintl = cc.find_library('intl', required : false)
|
@ -1,6 +1,6 @@
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -944,7 +944,7 @@ if host_system == 'windows' and (cc.get_
|
||||
@@ -949,7 +949,7 @@ if host_system == 'windows' and (cc.get_
|
||||
glib_conf.set('HAVE_C99_SNPRINTF', false)
|
||||
glib_conf.set('HAVE_C99_VSNPRINTF', false)
|
||||
glib_conf.set('HAVE_UNIX98_PRINTF', false)
|
||||
|
@ -20,10 +20,9 @@ PKG_LICENSE:=GPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/tang
|
||||
SECTION:=utils
|
||||
@ -56,6 +55,7 @@ if [ -z "$${IPKG_INSTROOT}" ]; then
|
||||
KEYS=$(find /usr/share/tang/db/ -name "*.jw*" -maxdepth 1 | wc -l)
|
||||
if [ "${KEYS}" = "0" ]; then # if db is empty generate new key pair
|
||||
/usr/libexec/tangd-keygen /usr/share/tang/db/
|
||||
fi
|
||||
(cat /etc/services | grep -E "tangd.*8888\/tcp") > /dev/null \
|
||||
|| echo -e "tangd\t\t8888/tcp" >> /etc/services
|
||||
fi
|
||||
|
@ -1,22 +1,21 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=zstd
|
||||
PKG_VERSION:=1.4.9
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=1.5.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.zst
|
||||
PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
|
||||
PKG_HASH:=61dce0e9a5036d7fb9b5709ee6567c2c8a1b4ba48a8e43afe9ae355cc37bb494
|
||||
PKG_HASH:=9aa8dfc1ca17f358b28988ca1f6e00ffe1c6f3198853f8d2022799e6f0669180
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
MESON_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/build/meson/openwrt-build
|
||||
|
||||
@ -64,16 +63,15 @@ ifeq ($(CONFIG_ZSTD_OPTIMIZE_O3),y)
|
||||
TARGET_CFLAGS:= $(filter-out -O%,$(TARGET_CFLAGS)) -O3
|
||||
endif
|
||||
|
||||
TARGET_CFLAGS += $(if $(CONFIG_USE_UCLIBC),-D_BSD_SOURCE)
|
||||
|
||||
MESON_ARGS += \
|
||||
-Dlegacy_level=1 \
|
||||
-Dlegacy_level=7 \
|
||||
-Ddebug_level=0 \
|
||||
-Dbacktrace=false \
|
||||
-Dstatic_runtime=false \
|
||||
-Dbin_programs=true \
|
||||
-Dbin_tests=false \
|
||||
-Dbin_control=false \
|
||||
-Dbin_contrib=false \
|
||||
-Dmulti_thread=enabled \
|
||||
-Dzlib=disabled \
|
||||
-Dlzma=disabled \
|
||||
-Dlz4=disabled \
|
||||
|
@ -1,11 +0,0 @@
|
||||
Fixes build issue https://github.com/facebook/zstd/issues/2519
|
||||
--- a/build/meson/lib/meson.build
|
||||
+++ b/build/meson/lib/meson.build
|
||||
@@ -22,6 +22,7 @@ libzstd_sources = [join_paths(zstd_rootd
|
||||
join_paths(zstd_rootdir, 'lib/common/threading.c'),
|
||||
join_paths(zstd_rootdir, 'lib/common/pool.c'),
|
||||
join_paths(zstd_rootdir, 'lib/common/zstd_common.c'),
|
||||
+ join_paths(zstd_rootdir, 'lib/common/zstd_trace.c'),
|
||||
join_paths(zstd_rootdir, 'lib/common/error_private.c'),
|
||||
join_paths(zstd_rootdir, 'lib/common/xxhash.c'),
|
||||
join_paths(zstd_rootdir, 'lib/compress/hist.c'),
|
Loading…
Reference in New Issue
Block a user